summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2023-09-19 10:49:40 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2023-09-19 10:49:40 +0800
commitd678b748b4830d55d21b79846f245e6e11aba274 (patch)
tree959b0b2131cc89960d5e705789a7335321081192
parent[net-dns/dog] new ebuild (diff)
downloadpigfoot-d678b748b4830d55d21b79846f245e6e11aba274.tar.gz
pigfoot-d678b748b4830d55d21b79846f245e6e11aba274.tar.bz2
pigfoot-d678b748b4830d55d21b79846f245e6e11aba274.zip
[net-dns/q] new ebuild
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
l---------net-dns/q/q-0.12.0.ebuild1
-rw-r--r--net-dns/q/q-9999.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-dns/q/q-0.12.0.ebuild b/net-dns/q/q-0.12.0.ebuild
new file mode 120000
index 0000000..dd1a1f1
--- /dev/null
+++ b/net-dns/q/q-0.12.0.ebuild
@@ -0,0 +1 @@
+q-9999.ebuild \ No newline at end of file
diff --git a/net-dns/q/q-9999.ebuild b/net-dns/q/q-9999.ebuild
new file mode 100644
index 0000000..1cfec4c
--- /dev/null
+++ b/net-dns/q/q-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGO_PN="github.com/natesales/${PN}"
+
+inherit go-module
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGO_VER="devel"
+
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
+else
+ EGO_VER="v${PV}"
+ #SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGIT_COMMIT="${EGO_VER}"
+
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
+
+ KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
+fi
+
+DESCRIPTION="A tiny command line DNS client with support for UDP, TCP, DoT, DoH, DoQ and ODoH"
+LICENSE="GPL-3"
+SLOT="0/${PVR}"
+RESTRICT="mirror"
+IUSE="+pie"
+
+src_compile() {
+ # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
+ # https://github.com/golang/go/issues/18968
+ use pie && local build_pie="-buildmode=pie"
+
+ local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
+ local ld_flags="$( echo "-s -w -X 'main.version=${EGO_VER}' -X 'main.commit=${EGIT_VERSION}' -X 'main.date=$(date --iso-8601=seconds)'" )"
+
+ set -- env \
+ CGO_ENABLED=0 \
+ go build -o "bin/${PN}" -mod=vendor -v -work -x ${build_flags} -ldflags "${ld_flags}" \
+ .
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ dobin bin/*
+}