aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-10-02 18:49:49 +0100
committerPaul Healy <lmiphay@gmail.com>2018-10-02 18:49:49 +0100
commitb92e374aed0a217e2b8ac832753002c756037759 (patch)
tree6e4cf427e1a7d9a2af1687b52147a6bf0b734157 /sys-apps
parentrevbump pasystray (diff)
downloadlmiphay-b92e374aed0a217e2b8ac832753002c756037759.tar.gz
lmiphay-b92e374aed0a217e2b8ac832753002c756037759.tar.bz2
lmiphay-b92e374aed0a217e2b8ac832753002c756037759.zip
add dstat with fixed tests
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dstat/Manifest3
-rw-r--r--sys-apps/dstat/dstat-0.7.3-r1.ebuild39
-rw-r--r--sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch15
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/dstat/Manifest b/sys-apps/dstat/Manifest
new file mode 100644
index 0000000..0a89bf2
--- /dev/null
+++ b/sys-apps/dstat/Manifest
@@ -0,0 +1,3 @@
+AUX dstat-0.7.3-skip-non-sandbox-tests.patch 705 BLAKE2B 3a20e75fd1aaed47d02066b7c889c13b4e1d8a2f8fd9772973d99736eb7cdf1fa9b8c04126beace166a6ac65de5de8743b904e9fa20d60a3aeae706f7ca41d18 SHA512 efa1c6a807efc7fabf8566ec446be94922e1fe78191101648dc066f107474f1b89c4c8cac51d6d1ba7d4b1061ce0358abf317761ce52199479667da1684f0929
+DIST dstat-0.7.3.tar.gz 135583 BLAKE2B c846a06b6039e49944d43cc36178fed74fd4e0e3a1a4418dbe0e5987763995eb36dff0245cfa7107d446b8ac2ea500e13980f87e97aa8e5b8d566ee188be1639 SHA512 db37cc8bb7afd235ae9088e76c4defaa4d76651b111fbfdcd0980bc96376de20d57964912799a413397a79651730503bdeb8fea5cb97ab4d6d81632f528aefd2
+EBUILD dstat-0.7.3-r1.ebuild 865 BLAKE2B 60f79ac34d777a864ad9aaa154346323b7818e219833ff152597cf1f148f60439e19430e303b0ca3fc66c69538fde1d3744d91246fe5779644a73c77558fe52a SHA512 b4462000fcd9ff5554f6e3c5571997e0db595613efb13eaf7fe2a722a79e5115046039fd09ecac7578b661c6aec15a4180ff53f87dee51e17b3b9e11f95cfbe0
diff --git a/sys-apps/dstat/dstat-0.7.3-r1.ebuild b/sys-apps/dstat/dstat-0.7.3-r1.ebuild
new file mode 100644
index 0000000..372d70a
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="wifi doc examples"
+REQUIRED_USE="wifi? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ wifi? (
+ ${PYTHON_DEPS}
+ net-wireless/python-wifi
+ )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" )
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}
diff --git a/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch b/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch
new file mode 100644
index 0000000..48eb542
--- /dev/null
+++ b/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch
@@ -0,0 +1,15 @@
+--- a/Makefile 2016-03-18 13:03:22.000000000 +0000
++++ b/Makefile 2018-10-02 11:11:00.344942941 +0100
+@@ -32,9 +32,11 @@
+ rm -f examples/*.pyc plugins/*.pyc
+ $(MAKE) -C docs clean
+
++TEST_PLUGINS=--cpufreq --disk-avgqu --disk-avgrq --disk-svctm --disk-tps --disk-util --disk-wait --dstat-cpu --dstat-ctxt --dstat-mem --dstat --helloworld --md-status --net-packets --proc-count --snooze --test --top-bio-adv --top-bio --top-childwait --top-cpu-adv --top-cpu --top-cputime-avg --top-cputime --top-int --top-io-adv --top-io --top-latency-avg --top-latency --top-mem --top-oom
++
+ test:
+ ./dstat -taf 1 5
+- ./dstat -t --all-plugins 1 5
++ ./dstat -t $(TEST_PLUGINS) 1 5
+
+ dist: clean
+ $(MAKE) -C docs dist