aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-07-09 12:04:05 +0100
committerPaul Healy <lmiphay@gmail.com>2022-07-09 12:04:05 +0100
commit222e22e82b7cb200d88f24947af27a3fae6f1746 (patch)
tree64b1d4792d17998fd5ede5599a4cd6d080c1a186 /dev-python
parentremove old kokua ebuild (diff)
downloadlmiphay-222e22e82b7cb200d88f24947af27a3fae6f1746.tar.gz
lmiphay-222e22e82b7cb200d88f24947af27a3fae6f1746.tar.bz2
lmiphay-222e22e82b7cb200d88f24947af27a3fae6f1746.zip
update flask restx for py 10
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask-restx/Manifest4
-rw-r--r--dev-python/flask-restx/flask-restx-0.2.0.ebuild53
-rw-r--r--dev-python/flask-restx/flask-restx-0.5.1.ebuild6
3 files changed, 4 insertions, 59 deletions
diff --git a/dev-python/flask-restx/Manifest b/dev-python/flask-restx/Manifest
index d098cae..5e3e6a4 100644
--- a/dev-python/flask-restx/Manifest
+++ b/dev-python/flask-restx/Manifest
@@ -1,5 +1,3 @@
AUX werkzeug.patch 1207 BLAKE2B d9b6ce335c98728dba344249970feb67f66972cf5a4d20829631e4fb8dadb31d42094253e9cd031d88ece8fe32ba5f517ec274cf6050de93c2c98459256f6242 SHA512 c1b5a8ca04abaf431b944efcd06417be720538138bf1fa3d3ede8d2b4ca0a4ed0a0d0669c0ac0b6c518f9f27a80eae83b2f9cbeb6c76043015d178f60ca21c7b
-DIST flask-restx-0.2.0.tar.gz 2606161 BLAKE2B 08a14829e6d2848a31f6200f060a9a744e65ed301027b350cd8e6d7b0b56e48f161e333834689653c0552affa2a89884466373e1c4280dd7898da6ec6fe18eab SHA512 baddd920437aced447fe388f127d2791e808f0103682507b48751d15d2879cb6a4033f0332d03255d085b3db0a18307e157a4fe90e7dc23f2deedfc5785f4f48
DIST flask-restx-0.5.1.tar.gz 5282772 BLAKE2B a3094a44b24d1eadbda2143df9bad125b1f63379177150e7b83fe679614b8751fa3c6f944ab7bddd81d5483c282f0601f966288c648763b913b87bbdb6ec721e SHA512 6eb357b2650862aa8f1181808967b573b8956d24d38f32280a286d204191ba30eb661f058699b0f768c5778297ed28480ab7781b153a5035e66bb62d16f1421b
-EBUILD flask-restx-0.2.0.ebuild 1194 BLAKE2B 0497396ced5c7e5c79698fe25ab7086d6f369369825816b77a1fba381cfffba6e3508f92196ab3748fc4f643cd45cd97830109927fa98de0c279b4eef1177a44 SHA512 1b609ef78cc07c61c1f3bee9528ddde758a31be13337287cee453385ede7753987869083b841b71e948ab551af61e442cfda6e7bf0ea94069e83214d4fce410a
-EBUILD flask-restx-0.5.1.ebuild 1173 BLAKE2B 99c09f88dd32152575d43ddc95ef846f5bb3b4ddb75950430922043226943b81268dbbd9fcdf81d3e36f3d6f78d40ae73023af16712bb03ec4416a6211654f79 SHA512 8d2770fcb964fd5503a21180fdae67bdbd95f1b83c09c72636a835c41db819a6fb89704b7b4c6fda745d38b31031c92f58459998980e26eb8a362530e5b49d7a
+EBUILD flask-restx-0.5.1.ebuild 1174 BLAKE2B a9e4a0592f66fe69e2fcf321ad8e609af3cdec9d682b2e52be4026addc800b7bb1176298d1ba28562c530fc44f5b0b2fbcecb2165fdf0543d380ae44dcc25f09 SHA512 c3c392592e885199eaafcdc6755f8cd7300a610dd417671596fb43e2d4bd0ab92be2379712a5784c2db0978200271e68f0cedad5ae79e75392f18c0e75317a5f
diff --git a/dev-python/flask-restx/flask-restx-0.2.0.ebuild b/dev-python/flask-restx/flask-restx-0.2.0.ebuild
deleted file mode 100644
index 5ce9da8..0000000
--- a/dev-python/flask-restx/flask-restx-0.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6..9} )
-inherit distutils-r1
-
-DESCRIPTION="Framework for fast, easy, and documented API development with Flask"
-HOMEPAGE="https://github.com/python-restx/flask-restx"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dev doc test"
-RESTRICT="
- !test? ( test )
-"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- >=dev-python/aniso8601-0.82
- dev-python/jsonschema
- >=dev-python/flask-0.8
- dev-python/pytz
- >=dev-python/six-1.3.0
- dev-python/werkzeug
- dev? (
- =dev-python/black-19.10_beta0
- =dev-python/tox-3.13.2
- )
- doc? (
- =dev-python/alabaster-0.7.12
- =dev-python/sphinx-2.1.2
- =dev-python/sphinx-issues-1.2.0
- )
- test? (
- dev-python/blinker
- =dev-python/faker-2.0.0
- =dev-python/mock-3.0.5
- dev-python/ossaudit
- =dev-python/pytest-5.0.1
- =dev-python/pytest-benchmark-3.2.2
- =dev-python/pytest-cov-2.7.1
- =dev-python/pytest-flask-0.15.1
- =dev-python/pytest-mock-1.10.4
- =dev-python/pytest-profiling-1.7.0
- =dev-python/pytest-sugar-0.9.2
- =dev-python/readme-renderer-24.0
- dev-python/tzlocal
- )
-"
diff --git a/dev-python/flask-restx/flask-restx-0.5.1.ebuild b/dev-python/flask-restx/flask-restx-0.5.1.ebuild
index 23e7e8b..822824b 100644
--- a/dev-python/flask-restx/flask-restx-0.5.1.ebuild
+++ b/dev-python/flask-restx/flask-restx-0.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{8..9} )
+PYTHON_COMPAT=( pypy3 python3_{9..10} )
inherit distutils-r1
DESCRIPTION="Framework for fast, easy, and documented API development with Flask"