aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2020-04-17 13:56:16 +0100
committerPaul Healy <lmiphay@gmail.com>2020-04-17 13:56:16 +0100
commit39ea99cf5ab8fc84de1bb2cdaa007d188a814921 (patch)
tree885aba8bb5e415fdd90b93df22208b6798130b80
parentremove old ebuilds (diff)
downloadlmiphay-39ea99cf5ab8fc84de1bb2cdaa007d188a814921.tar.gz
lmiphay-39ea99cf5ab8fc84de1bb2cdaa007d188a814921.tar.bz2
lmiphay-39ea99cf5ab8fc84de1bb2cdaa007d188a814921.zip
revbump homeassistant
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--app-misc/homeassistant-bin/Manifest1
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-0.108.6.ebuild145
-rw-r--r--dev-util/clion/clion-2019.1.ebuild65
-rw-r--r--homeassistant.keywords4
4 files changed, 148 insertions, 67 deletions
diff --git a/app-misc/homeassistant-bin/Manifest b/app-misc/homeassistant-bin/Manifest
index 99305ff..23d1b3a 100644
--- a/app-misc/homeassistant-bin/Manifest
+++ b/app-misc/homeassistant-bin/Manifest
@@ -6,4 +6,5 @@ AUX recorder.yaml 114 BLAKE2B af04840805aa13124208584e7f1d40335905a083ee7deead5c
AUX update-homeassistant 1672 BLAKE2B b8a99eb0f13847e28acc5f52a2313973d791e5993f76490e534f73f188fd44895dfac5d751226bc769787d466a0d8bbdb3ec369dc8a0cedd7144fce779cd9de0 SHA512 26e0cfc66f2d48218db7fe6b3e9c0b92d765f6eb6c91bc39aedb56c6d6f419ce263c8d47637936622c8afcdf0cb7c1864e249cd190a110ea996cb4eff5122a81
EBUILD homeassistant-bin-0.107.7.ebuild 4256 BLAKE2B d5b948fbac39f55786b8de55015545aae7eff3abc9d13a40dc4ecf600daba59c570dd1ca6d6af69b0d36859aa600b14abbaf834eddc2d05e2659b587fac145f9 SHA512 ded2a7a8f183674643832004a2779281dc67b494372ad76dea72b7097623e0890fcb34b84f9a384bfdd4c210e3d3803f8046e91ad8a09455e5603b585398e632
EBUILD homeassistant-bin-0.108.2.ebuild 4256 BLAKE2B d5b948fbac39f55786b8de55015545aae7eff3abc9d13a40dc4ecf600daba59c570dd1ca6d6af69b0d36859aa600b14abbaf834eddc2d05e2659b587fac145f9 SHA512 ded2a7a8f183674643832004a2779281dc67b494372ad76dea72b7097623e0890fcb34b84f9a384bfdd4c210e3d3803f8046e91ad8a09455e5603b585398e632
+EBUILD homeassistant-bin-0.108.6.ebuild 4256 BLAKE2B d5b948fbac39f55786b8de55015545aae7eff3abc9d13a40dc4ecf600daba59c570dd1ca6d6af69b0d36859aa600b14abbaf834eddc2d05e2659b587fac145f9 SHA512 ded2a7a8f183674643832004a2779281dc67b494372ad76dea72b7097623e0890fcb34b84f9a384bfdd4c210e3d3803f8046e91ad8a09455e5603b585398e632
EBUILD homeassistant-bin-9999.ebuild 2570 BLAKE2B a585a757290d38e61908524df8282b8d48916b7c23cb2b51e625d6d08ca409b6ef357f5bc06f1d1022bbfc4120112e292dac343f20692b11db8e1e66e15cf104 SHA512 c22d886de264eac1cc4bb3f7ecd7824ca4edac987f80ce29661c865557413f08399f2cd26683bf91fbeec99be0d92e390b04a246d0219de2398d19dedee1637d
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-0.108.6.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-0.108.6.ebuild
new file mode 100644
index 0000000..e6ad1c2
--- /dev/null
+++ b/app-misc/homeassistant-bin/homeassistant-bin-0.108.6.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit user readme.gentoo-r1 eutils distutils-r1 systemd
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Home automation platform (Python 3 required)"
+HOMEPAGE="https://home-assistant.io"
+SRC_URI="" # pip installs HA version $PV from PyPI
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="maint mysql"
+
+PY_HA="3.7"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ !app-misc/homeassistant
+ dev-lang/python:${PY_HA}
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysqlclient )
+"
+RDEPEND="
+ ${DEPEND}
+ app-admin/logrotate
+ maint? (
+ app-crypt/certbot
+ app-crypt/ssl-cert-check
+ net-misc/dropbox-uploader
+ virtual/logger
+ )
+"
+
+INSTALL_DIR="/opt/${MY_PN}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+ The HA interface listens on port 8123 - this _will_ take a minute or two to appear
+
+ hass configuration is in: /etc/${MY_PN}
+ For openrc daemon command line arguments are configured in: /etc/conf.d/${MY_PN}
+
+ logging is to: /var/log/${MY_PN}/{server,errors,stdout}.log
+ For HA logging configuration see: https://www.home-assistant.io/components/logger/
+
+ The sqlite db is by default in: /etc/${MY_PN}
+ To move it after ${MY_PN} has run once and while ${MY_PN} is stopped:
+ - add /etc/${MY_PN}/recorder.yaml to /etc/${MY_PN}/configuration.yaml
+ - mv /etc/${MY_PN}/home-assistant_v2.db /var/db/${MY_PN}
+
+ support thread at:
+ https://community.home-assistant.io/t/gentoo-homeassistant-0-59-2-ebuild/35577
+
+ The script /usr/bin/update-homeassistant can be used to update homeassistant-bin (it keeps
+ a backup of the previous virtualenv under /opt). The script is for openrc only at the moment.
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ enewgroup "${MY_PN}"
+ enewuser "${MY_PN}" -1 -1 "$INSTALL_DIR" "${MY_PN}"
+
+ elog "This ebuild requires network access for 'pip install $MY_PN'"
+ elog "If the install fails due to name lookup retrying out, then try"
+ elog "disabling the portage network-sandbox ; e.g. in /etc/portage/make.conf:"
+ elog ""
+ elog "FEATURES=\"-network-sandbox\""
+ elog ""
+ elog "The update-homeassistant script temporally disables the network-sandbox (and can"
+ elog "also be used to do an initial install of ${PN})."
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin "${FILESDIR}/update-homeassistant"
+
+ keepdir "$INSTALL_DIR"
+
+ keepdir "/etc/${MY_PN}"
+ insinto "/etc/${MY_PN}"
+ doins "${FILESDIR}/recorder.yaml"
+ fowners -R "${MY_PN}:${MY_PN}" "/etc/${MY_PN}"
+
+ "python${PY_HA}" -m venv "${D}/$INSTALL_DIR"
+ # for no output from pip add: --quiet
+ # note the venv has a python3, but no python3.x
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "${MY_PN}==${PV}" || die
+ sed -i "1c#!$INSTALL_DIR/bin/python3" "${D}/$INSTALL_DIR/bin/hass"
+
+ # see: https://github.com/home-assistant/home-assistant/issues/28198#issuecomment-546300192
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "home-assistant-frontend" || die
+
+ if use mysql ; then
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "mysqlclient" || die
+ fi
+
+ # this has to come after all of the package installs
+ fowners -R "${MY_PN}:${MY_PN}" "$INSTALL_DIR"
+
+ newconfd "${FILESDIR}/${MY_PN}.conf.d" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
+
+ keepdir "/var/log/${MY_PN}/old"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/log/${MY_PN}"
+
+ keepdir "/var/db/${MY_PN}"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/db/${MY_PN}"
+
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ elog "homeassistant requires python 3.5 (or later)"
+ elog ""
+ elog "This ebuild installs homeassistant into a virtualenv built for:"
+ elog ""
+ elog " python ${PY_HA} (the current python 3.x in gentoo PYTHON_TARGETS)"
+ elog ""
+ elog "If you have previously run homeassistant with an older version of "
+ elog "python, then it is recommended that you do a clean install on moving to"
+ elog "python ${PY_HA}."
+
+ readme.gentoo_print_elog
+}
+
+pkg_config() {
+ "${INSTALL_DIR}/bin/hass" --script ensure_config
+}
diff --git a/dev-util/clion/clion-2019.1.ebuild b/dev-util/clion/clion-2019.1.ebuild
deleted file mode 100644
index f6d25d7..0000000
--- a/dev-util/clion/clion-2019.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop eutils
-
-DESCRIPTION="A complete toolset for C and C++ development"
-HOMEPAGE="http://www.jetbrains.com/clion"
-SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="IDEA
- || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="splitdebug"
-IUSE="custom-jdk"
-
-# RDEPENDS may cause false positives in repoman.
-# clion requires cmake and gdb at runtime to build and debug C/C++ projects
-RDEPEND="
- dev-util/cmake
- sys-devel/gdb
- !custom-jdk? ( virtual/jdk )"
-
-QA_PREBUILT="opt/${P}/*"
-
-src_prepare() {
- default
-
- local remove_me=(
- bin/gdb/linux
- bin/lldb/linux
- bin/cmake
- license/CMake*
- )
-
- use arm || remove_me+=( bin/fsnotifier-arm )
-
- use custom-jdk || remove_me+=( jre64 )
-
- rm -rv "${remove_me[@]}" || die
-}
-
-src_install() {
- local dir="/opt/${P}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64},clang/linux/clang{d,-tidy}}
-
- if use custom-jdk; then
- if [[ -d jre64 ]]; then
- fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
- fi
- fi
-
- make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
- newicon "bin/${PN}.svg" "${PN}.svg"
- make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- dodir /usr/lib/sysctl.d/
- echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
-}
diff --git a/homeassistant.keywords b/homeassistant.keywords
index 0e3ebc0..eec5e47 100644
--- a/homeassistant.keywords
+++ b/homeassistant.keywords
@@ -1,5 +1,5 @@
-#=app-misc/homeassistant-bin-0.107.7 ~amd64
-=app-misc/homeassistant-bin-0.108.2 ~amd64
+#=app-misc/homeassistant-bin-0.108.2 ~amd64
+=app-misc/homeassistant-bin-0.108.6 ~amd64
=app-homeassistant/simple-thermostat-0.21.0 ~amd64