summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-01-30 23:28:41 -0500
committerJustin Riley <justin.t.riley@gmail.com>2012-01-30 23:28:41 -0500
commit54697a74ce738fe52be3c040ad2ebcaf38bff2cd (patch)
tree8800d38e643f31d4b974fb1d319e2254042f72d4 /dev-python
parentadd ctypeslib live development ebuild (diff)
downloadjtriley-54697a74ce738fe52be3c040ad2ebcaf38bff2cd.tar.gz
jtriley-54697a74ce738fe52be3c040ad2ebcaf38bff2cd.tar.bz2
jtriley-54697a74ce738fe52be3c040ad2ebcaf38bff2cd.zip
add cx_freeze 4.0 ebuild
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cx_freeze/cx_freeze-4.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/cx_freeze/cx_freeze-4.0-r1.ebuild b/dev-python/cx_freeze/cx_freeze-4.0-r1.ebuild
new file mode 100644
index 0000000..00199e9
--- /dev/null
+++ b/dev-python/cx_freeze/cx_freeze-4.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+#That crazy "b" is not allowed :(
+MY_P="cx_Freeze-4.0b1"
+#Other desc: create standalone executables from Python scripts
+DESCRIPTION="A set of utilities for freezing Python scripts into executables"
+HOMEPAGE="http://www.cxtools.net/default.aspx?nav=cxfrlb"
+SRC_URI="http://surfnet.dl.sourceforge.net/sourceforge/cx-freeze/${MY_P}.tar.gz"
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+#DEPEND=""
+#RDEPEND=""
+S=${WORKDIR}/${MY_P}
+
+src_install(){
+ distutils_src_install
+}
+