summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-06-12 10:37:28 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-06-12 10:37:28 -0400
commit5deee0acc57818dc22d5ec737d4ce152c703a6df (patch)
tree6ab7ff0b2222822c5ecd955abcf861e1e1eb6681
parentvmware-modules: use ebuild from gmt overlay (3.14.x support) (diff)
downloadjtriley-5deee0acc57818dc22d5ec737d4ce152c703a6df.tar.gz
jtriley-5deee0acc57818dc22d5ec737d4ce152c703a6df.tar.bz2
jtriley-5deee0acc57818dc22d5ec737d4ce152c703a6df.zip
vmware-modules: fix for kernel 3.15.0
-rw-r--r--app-emulation/vmware-modules/files/279-3.15.0.patch55
-rw-r--r--app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild1
2 files changed, 56 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/279-3.15.0.patch b/app-emulation/vmware-modules/files/279-3.15.0.patch
new file mode 100644
index 0000000..7749f9a
--- /dev/null
+++ b/app-emulation/vmware-modules/files/279-3.15.0.patch
@@ -0,0 +1,55 @@
+--- vsock-only/linux/notify.c 2014-04-14 23:36:15.779380482 +0200
++++ vsock-only/linux/notify.c.new 2014-04-14 23:36:41.396381914 +0200
+@@ -516,7 +516,11 @@
+ PKT_FIELD(vsk, sentWaitingRead) = FALSE;
+ #endif
+
++#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 14, 99)
+ sk->sk_data_ready(sk, 0);
++#else
++ sk->sk_data_ready(sk);
++#endif
+ }
+
+
+--- vsock-only/linux/notifyQState.c 2013-10-18 19:56:12.000000000 +0200
++++ vsock-only/linux/notifyQState.c.new 2014-04-14 23:37:53.316385936 +0200
+@@ -164,7 +164,11 @@
+ struct sockaddr_vm *dst, // IN: unused
+ struct sockaddr_vm *src) // IN: unused
+ {
++#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 14, 99)
+ sk->sk_data_ready(sk, 0);
++#else
++ sk->sk_data_ready(sk);
++#endif
+ }
+
+
+@@ -566,7 +570,12 @@
+ }
+
+ /* See the comment in VSockVmciNotifyPktSendPostEnqueue */
++
++#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 14, 99)
+ sk->sk_data_ready(sk, 0);
++#else
++ sk->sk_data_ready(sk);
++#endif
+ }
+
+ return err;
+--- vmblock-only/linux/inode.c 2014-04-14 23:25:31.755344470 +0200
++++ vmblock-only/linux/inode.c.new 2014-04-14 23:23:31.732337759 +0200
+@@ -178,7 +178,11 @@
+ return -EINVAL;
+ }
+
++#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 14, 99)
+ return vfs_readlink(dentry, buffer, buflen, iinfo->name);
++#else
++ return readlink_copy(buffer, buflen, iinfo->name);
++#endif
+ }
+
+
diff --git a/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
index 345ecc0..2dc4390 100644
--- a/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
@@ -105,6 +105,7 @@ src_prepare() {
# 3.12.x and 3.13.x patches
kernel_is ge 3 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.12.0.patch"
kernel_is ge 3 14 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.14.0.patch"
+ kernel_is ge 3 15 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.15.0.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user