aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cookbook/cookbook-2.2.9.ebuild')
-rw-r--r--dev-python/cookbook/cookbook-2.2.9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cookbook/cookbook-2.2.9.ebuild b/dev-python/cookbook/cookbook-2.2.9.ebuild
new file mode 100644
index 0000000..cfe7551
--- /dev/null
+++ b/dev-python/cookbook/cookbook-2.2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+inherit distutils
+
+DESCRIPTION="This implements some recipes from the python cookbook"
+HOMEPAGE="http://pypi.python.org/pypi/cookbook/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-python/bunch
+ doc? ( dev-python/jinja
+ dev-python/pytables
+ sci-libs/scipy )"
+
+src_compile() {
+ distutils_src_compile
+
+ build_docs() {
+ PYTHONPATH=../python/ emake -C docs html
+ }
+ use doc && python_execute_function -f build_docs
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/build/html/
+ fi
+}