aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-04-24 02:11:05 +0800
committerIan Delaney <della5@iinet.com.au>2012-04-24 02:11:05 +0800
commit468e6c88722d341e74864e1e4006fa4d318bf23c (patch)
treee1757358bddbcfb732c5018f07c1b77004ae3d13
parent[dev-python/django-[appconf,compressor],errorhandler] revised (diff)
downloadimprovise-468e6c88722d341e74864e1e4006fa4d318bf23c.tar.gz
improvise-468e6c88722d341e74864e1e4006fa4d318bf23c.tar.bz2
improvise-468e6c88722d341e74864e1e4006fa4d318bf23c.zip
[dev-python/beautifulsoup4] New ebuild, update tampakrap req file
-rw-r--r--dev-python/beautifulsoup4/Manifest1
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.0.4.ebuild50
-rw-r--r--dev-python/beautifulsoup4/metadata.xml11
-rw-r--r--dev-python/django-appconf/django-appconf-0.5.ebuild19
-rw-r--r--dev-python/django-compressor/django-compressor-1.1.2.ebuild6
-rw-r--r--sets/tampakrap-requested-packages1
6 files changed, 75 insertions, 13 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
new file mode 100644
index 0000000..9ff4959
--- /dev/null
+++ b/dev-python/beautifulsoup4/Manifest
@@ -0,0 +1 @@
+DIST beautifulsoup4-4.0.4.tar.gz 120837 SHA256 38c0b6d9cf9cee271bb27da9e5c1f19f7ff527750bbe7e0cbd75cc18fbbaee6a SHA512 3f069e38632ca7ad516f82a27220a56a13c438b59f4ecc015a1950c5a00f1d4c1b1fab3b5bf346f2768bddbf879dc95582418b026967eab412365f80957672ab WHIRLPOOL 1977dd28fbd4c89b3e1e5e52832f002b57b8c881f83a228cc65bbf5abc9fbc4d6c6367fb6ba220481abfaafac86a741add8fedbdc3fb29a4b805a61d1428a823
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.0.4.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.0.4.ebuild
new file mode 100644
index 0000000..fd5fe00
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.5"
+#PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Pproves Pythonic idioms for iterating, searching, and modifying the parse tree"
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+PYTHON_MODNAME="bs4"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+#dirhtml; singlehtml; pickle; json; htmlhelp; qthelp; devhelp; epub; latex; latexpdf; text; man
+
+ if use doc; then
+ emake -j1 -C doc epub latex man
+ fi
+ distutils_src_compile
+}
+
+src_test() {
+ testing() {
+ cd "${S}/build-${PYTHON_ABI}/lib"
+ nosetests --verbosity="${PYTHON_TEST_VERBOSITY}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ if use doc; then
+ dohtml -r doc
+ fi
+ distutils_src_install
+}
diff --git a/dev-python/beautifulsoup4/metadata.xml b/dev-python/beautifulsoup4/metadata.xml
new file mode 100644
index 0000000..5366461
--- /dev/null
+++ b/dev-python/beautifulsoup4/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer><email>tampakrap@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>della5@iinet.com.au</email>
+ <name>Ian Delaney aka idella4 proxy maintainer</name>
+ </maintainer>
+
+</pkgmetadata>
diff --git a/dev-python/django-appconf/django-appconf-0.5.ebuild b/dev-python/django-appconf/django-appconf-0.5.ebuild
index e0c9bd0..4d8546e 100644
--- a/dev-python/django-appconf/django-appconf-0.5.ebuild
+++ b/dev-python/django-appconf/django-appconf-0.5.ebuild
@@ -5,11 +5,12 @@
EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*" # works AOK with pypy
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
DESCRIPTION="A helper class for handling configuration defaults of packaged apps gracefully"
-HOMEPAGE="http://pypi.python.org/pypi/django-appconf/"
+HOMEPAGE="http://pypi.python.org/pypi/django-appconf http://django-appconf.readthedocs.org//"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
@@ -32,28 +33,28 @@ src_prepare() {
src_compile() {
if use doc; then
- emake -C docs pickle htmlhelp
+ emake -j1 -C docs pickle html
fi
+ distutils_src_compile
}
src_test() {
export DJANGO_SETTINGS_MODULE="django.conf"
testing() {
PYTHONPATH=. "$(PYTHON)" appconf/tests/tests.py
- einfo "tests completed successfully"
+ einfo "tests completed successfully for python"$(python_get_version)
+ einfo ""
}
+
python_execute_function testing
}
src_install() {
if use doc; then
- dohtml -r docs/
- mv ${ED}usr/share/doc/${PF}/html/_build/{htmlhelp,pickle} ${ED}usr/share/doc/${PF}/html/ \
- || die
- rmdir ${ED}usr/share/doc/${PF}/html/_build || die
+ dohtml -r docs/_build
insinto usr/share/doc/${PF}/html/doctrees
- doins docs/_build/doctrees/*
+ doins -r docs/_build/doctrees/
fi
distutils_src_install
diff --git a/dev-python/django-compressor/django-compressor-1.1.2.ebuild b/dev-python/django-compressor/django-compressor-1.1.2.ebuild
index ccab4fc..f42c302 100644
--- a/dev-python/django-compressor/django-compressor-1.1.2.ebuild
+++ b/dev-python/django-compressor/django-compressor-1.1.2.ebuild
@@ -22,7 +22,7 @@ PYTHON_MODNAME="compressor"
# tests I think worked in the live ebuild fine. It's tripping over a
# setting missing; COMPRESS_ROOT in compressor/conf.py
-#RESTRICT="test"
+RESTRICT="test"
S=${WORKDIR}/${MY_PN}-${PV}
RDEPEND=""
@@ -42,7 +42,7 @@ src_test() {
einfo "Test "${test}" completed OK"
done
}
- python_execute_function -s testing
+ python_execute_function testing
}
src_install() {
@@ -50,4 +50,4 @@ src_install() {
if use doc; then
dohtml -r compressor/
fi
-} \ No newline at end of file
+}
diff --git a/sets/tampakrap-requested-packages b/sets/tampakrap-requested-packages
index fb8a3ca..6bcd94b 100644
--- a/sets/tampakrap-requested-packages
+++ b/sets/tampakrap-requested-packages
@@ -28,7 +28,6 @@ kde-misc/nvidiadevicemonitor
# http://pypi.python.org/pypi/django_compressor/1.1.2
# http://pypi.python.org/pypi/nose-cover3/0.1.0 # https://github.com/iksaif/
# http://pypi.python.org/pypi/cl # https://github.com/iksaif/
-# http://pypi.python.org/pypi/multiprocessing
# http://pypi.python.org/pypi/django-celery/2.5.4 # https://github.com/iksaif/
# http://pypi.python.org/pypi/django-appconf/ # dep of django-compressor
# http://pypi.python.org/pypi/celery/ # https://github.com/iksaif/