aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-16 05:29:47 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-16 05:29:47 +0800
commit3a10eaa220f56ed442f5d8168595833368f53914 (patch)
tree4c4b1ece6d378ce6c10ce6ddd3a8edf4cd4e3d6e
parent[dev-python/xlutils] x86 -> ~x86 in ebuild (diff)
downloadimprovise-3a10eaa220f56ed442f5d8168595833368f53914.tar.gz
improvise-3a10eaa220f56ed442f5d8168595833368f53914.tar.bz2
improvise-3a10eaa220f56ed442f5d8168595833368f53914.zip
[dev-python/django-pipeline] bump 1.2.6, refined
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/django-pipeline/Manifest2
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.6.ebuild (renamed from dev-python/django-pipeline/django-pipeline-1.2.5.ebuild)12
2 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
index 82b0ebe..a64494a 100644
--- a/dev-python/django-pipeline/Manifest
+++ b/dev-python/django-pipeline/Manifest
@@ -1 +1 @@
-DIST django-pipeline-1.2.5.tar.gz 27027 SHA256 0bc87e8166c9bb9a5100a5826196667f5a42335f4331e10bf87bdcbfe70e795a SHA512 b7f0c4e95c76ef12f7f8cd9ccdf777ffc81ecf2de16d0680b801c68687f6e22619cc6e27a56f1317a2b91eb6cc6061361736cf6db76cd8773888bfd62f252d8a WHIRLPOOL a7d0e7889d9a1b0ba5423ca66a3e658f9760ba080a0ee06e3dd598aa2fe040079b7d1ab300e1dd1533d0038f5012e4dbdeac91a8074456e9ce3c0227b98e3261
+DIST django-pipeline-1.2.6.tar.gz 27135 SHA256 8de30a83ff1a1ea2683713580aae8be4ecc5bd1a4a22da6296115caaff67c60f SHA512 8dc02d1f0021179d4f430be18597f704d04c41580d523877bfe1206fa713f7ff7687f101ccd2dd50d1b729bf500015fc55303c740068d171bec41433eaf2a75a WHIRLPOOL 9847cedd633c75d04240e20b3529579701335bd29f21d3dc5f69a2146a887f7186c545775bd20b8933464957db7a9ddb329517be5a00ca2ec126524860211a84
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
index a11812a..4d955af 100644
--- a/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
@@ -19,14 +19,10 @@ LICENSE="MIT"
SLOT="0"
PYTHON_MODNAME="pipeline"
-RDEPEND=">=dev-python/django-1.4" #tests require >=1.4"
+RDEPEND=">=dev-python/django-1.4"
DEPEND="${RDEPEND}
dev-python/setuptools"
-src_prepare() {
- sed -e s':from pipeline.conf:from tests:' -i tests/tests/compiler.py || die
-}
-
src_compile() {
use doc && emake -C docs html
rm -f docs/_build/doctrees/environment.pickle || die
@@ -35,13 +31,13 @@ src_compile() {
src_test() {
export DJANGO_SETTINGS_MODULE="django.conf"
+ # Python.[56] trigger a harmless depracation warning
testing() {
local exit_status=0 test
- pushd build-${PYTHON_ABI}/lib/tests/tests > /dev/null || die
- PYTHONPATH=../../
+ pushd build-${PYTHON_ABI}/lib/tests/tests/ > /dev/null || die
for test in [a-z]*.py
do
- if ! "$(PYTHON)" ${test}; then
+ if ! PYTHONPATH=./../ "$(PYTHON)" ${test}; then
eerror "test "${test}" failed"
exit_status="1"
else