aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2016-02-12 22:54:59 +0100
committerNicholas Fish <gentoo@seaofdirac.net>2016-02-12 22:54:59 +0100
commit578ec8cdc7fa3838bd5c7c314815699e9c01ed8b (patch)
treee67af1116b45011dce6cc537e4d7da5581f6b253 /games-util/eureka/eureka-111.ebuild
parentAdd alsa-lib-1.1.0 ebuild with C99 uint types rather than Linux kernel u_int ... (diff)
downloadennui-578ec8cdc7fa3838bd5c7c314815699e9c01ed8b.tar.gz
ennui-578ec8cdc7fa3838bd5c7c314815699e9c01ed8b.tar.bz2
ennui-578ec8cdc7fa3838bd5c7c314815699e9c01ed8b.zip
Add a rough ebuild for eureka
Diffstat (limited to 'games-util/eureka/eureka-111.ebuild')
-rw-r--r--games-util/eureka/eureka-111.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-util/eureka/eureka-111.ebuild b/games-util/eureka/eureka-111.ebuild
new file mode 100644
index 0000000..568a0ff
--- /dev/null
+++ b/games-util/eureka/eureka-111.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Map editor for the classic DOOM games, and a few related games such as Heretic and Hexen."
+HOMEPAGE="http://eureka-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/eureka-editor/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-1.11-source
+
+DEPEND=">=x11-libs/fltk-1.3.0
+ sys-libs/zlib"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-gentoo-makefile.patch
+
+ eapply_user
+}
+