summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Baidakou <the.dmol@gmail.com>2012-08-05 21:21:52 +0300
committerIvan Baidakou <the.dmol@gmail.com>2012-08-05 21:21:52 +0300
commit99f723633c48bcdaaf220f97e4b1614ccb1b248a (patch)
tree44c6f481e115f5379da936045ae4c6eac551986e
parentebuild for nekohtml-1.9.16 wrt #426382 (diff)
downloaddmol-99f723633c48bcdaaf220f97e4b1614ccb1b248a.tar.gz
dmol-99f723633c48bcdaaf220f97e4b1614ccb1b248a.tar.bz2
dmol-99f723633c48bcdaaf220f97e4b1614ccb1b248a.zip
fontbox-1.7.1 ebuild wrt#430060
-rw-r--r--dev-java/fontbox/Manifest4
-rw-r--r--dev-java/fontbox/files/fontbox-1.7.1_maven-build.xml250
-rw-r--r--dev-java/fontbox/fontbox-1.7.1.ebuild42
-rw-r--r--dev-java/fontbox/metadata.xml7
4 files changed, 303 insertions, 0 deletions
diff --git a/dev-java/fontbox/Manifest b/dev-java/fontbox/Manifest
new file mode 100644
index 0000000..1ef5d24
--- /dev/null
+++ b/dev-java/fontbox/Manifest
@@ -0,0 +1,4 @@
+AUX fontbox-1.7.1_maven-build.xml 10618 RMD160 1b643d32b935264479b27d82dd4bff34aeea2674 SHA1 1f63e965dd21b6c0f60d542d14c15e78a7db2b26 SHA256 f00b70a1a7e4b1e83eb577a6e90248e42200d91c78176d3fb3be48af489194c4
+DIST pdfbox-1.7.1-src.zip 9167805 RMD160 a0c845609f4c67acee4eb92fab4b7a5f931a767a SHA1 bcdcf656a3e36381d2b8aa757bbf3c25234b8d5c SHA256 805c6b893ff10216cc826aa44e7a2eaf35bb43ca8ed19896c43132d253d3145e
+EBUILD fontbox-1.7.1.ebuild 873 RMD160 f925fe0847c60bff983bdf46450c5853b3d8ce7d SHA1 8ee7386e09a6933cee1a2e39ad562530f1f8f506 SHA256 d73a0a3279844f427698d5118321c162859a650b803d5d1d45bc076a5626a4ac
+MISC metadata.xml 205 RMD160 4923bb2153d0eb925ffc86f91fdd806110e016c0 SHA1 da9437a648cf7dd5fcfca1c45c60c4053fed15c4 SHA256 2ff0740a5424b0e10c7888541a248d1bd363a60911b0921b4cfe5c36590498ce
diff --git a/dev-java/fontbox/files/fontbox-1.7.1_maven-build.xml b/dev-java/fontbox/files/fontbox-1.7.1_maven-build.xml
new file mode 100644
index 0000000..ccde198
--- /dev/null
+++ b/dev-java/fontbox/files/fontbox-1.7.1_maven-build.xml
@@ -0,0 +1,250 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 8/2/12 1:39 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="fontbox-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="fontbox-1.7.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.8.1"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/fontbox/fontbox-1.7.1.ebuild b/dev-java/fontbox/fontbox-1.7.1.ebuild
new file mode 100644
index 0000000..a1c392e
--- /dev/null
+++ b/dev-java/fontbox/fontbox-1.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit java-pkg-2 java-ant-2
+MY_PN=pdfbox
+
+DESCRIPTION="An open source Java library for parsing font files"
+HOMEPAGE="http://pdfbox.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_PN}-${PV}-src.zip"
+
+LICENSE="BSD"
+SLOT="1.7"
+KEYWORDS="~amd64"
+
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ dev-java/ant-core
+ app-arch/unzip
+ test? ( dev-java/ant-junit:0 )
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${PN}"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/fontbox/metadata.xml b/dev-java/fontbox/metadata.xml
new file mode 100644
index 0000000..80859ae
--- /dev/null
+++ b/dev-java/fontbox/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>the.dmol@gmail.com</email>
+ </maintainer>
+</pkgmetadata>