summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Baidakou <the.dmol@gmail.com>2012-08-18 16:44:50 +0300
committerIvan Baidakou <the.dmol@gmail.com>2012-08-18 16:46:10 +0300
commit42ca533708256a1022c386b5aee5c7d226356f26 (patch)
treec667deb3033f0c93a2850c8fa3f13d7c85357081
parentcglib-3.2 version bump wrt#426380 (diff)
downloaddmol-42ca533708256a1022c386b5aee5c7d226356f26.tar.gz
dmol-42ca533708256a1022c386b5aee5c7d226356f26.tar.bz2
dmol-42ca533708256a1022c386b5aee5c7d226356f26.zip
new commons-digester-3.2.ebuild wrt#310357
-rw-r--r--dev-java/commons-digester/Manifest4
-rw-r--r--dev-java/commons-digester/commons-digester-3.2.ebuild55
-rw-r--r--dev-java/commons-digester/files/commons-digester-3.2_maven-build.xml338
-rw-r--r--dev-java/commons-digester/metadata.xml7
4 files changed, 404 insertions, 0 deletions
diff --git a/dev-java/commons-digester/Manifest b/dev-java/commons-digester/Manifest
new file mode 100644
index 0000000..ff06754
--- /dev/null
+++ b/dev-java/commons-digester/Manifest
@@ -0,0 +1,4 @@
+AUX commons-digester-3.2_maven-build.xml 15717 SHA256 dd0adb58088e4ae0d2907853148cd6617437ea7717e3b71149461cf1d46a2260 SHA512 c76b7aff00c7a625c99318e54db761a37f60b9146b4bfe2a7afcac6a5dcd6ddfff7aa5c855cbb52864e0b6c112ed5689d39f1ef7b8b12589c4bea46054d2866d WHIRLPOOL 1bc5b0620cbf61e5996e583c01e9e20131e64ec5c538c849d717254ec9d2227b4ec26f4e0bfee40d9c8ea2b0589926e93fb35ba09d00e6a1213eb1a82bda2425
+DIST commons-digester3-3.2-src.tar.gz 324555 SHA256 73fa7a8d3f0e39fbffae46cbd47cbf788c0a573e510a601928aa16ea1a0a6c0e SHA512 6d5ed9a1cc7612244747dcbd5c713349f27d63d1cef39fa368b4e91eaa3b1fe7043ab2fb498a73e8afde8081b8ff26a966e5b87b8b6dc68a3d907e9b25aa7cad WHIRLPOOL e4064f26a4cd88188436939ca6b2de582e84d4da1aca6d1931587643076f5a3b40701b3fef62fd5dff677e66f956f07314bf8eb7f3fece5780674ea63331ac48
+EBUILD commons-digester-3.2.ebuild 1329 SHA256 8281be948980dedbcf41daa13f328cd08f4bcc6e418ab8c0a792a86698a841a1 SHA512 1bc7bee49f1b73a25ff008b6a423e807663d11800e930694ce32023fb76f88303141965a8f1eb6b865aab7bb8497b2e2719869e31ce257931f968dfaf105a0ed WHIRLPOOL 2c3f52005ba97dae024fd673f44bf64450c6e50922ef865950a8c2c8c58f7c1f9f6d4fe62b563ea84e5a9316663f2b6f58c9478829b7d4f833443b5757d923b8
+MISC metadata.xml 205 SHA256 2ff0740a5424b0e10c7888541a248d1bd363a60911b0921b4cfe5c36590498ce SHA512 e7c77c724739d0af43cc338ded09dcbeee2a710eb0e49f1e656dc4c891bee85bfd6935bf70a191a1c5823f473643e676d64970416e5f1820ea466681016757c5 WHIRLPOOL 5b7f0c2a5243244fa06b072c8f0d9f53e7b6f45c7e1b74a0d945bdcc28b7137fddfd58e85b0d3e721e80963916ceae0d4cca59f48114ba26c47b24a91d6abb27
diff --git a/dev-java/commons-digester/commons-digester-3.2.ebuild b/dev-java/commons-digester/commons-digester-3.2.ebuild
new file mode 100644
index 0000000..10744bd
--- /dev/null
+++ b/dev-java/commons-digester/commons-digester-3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P="${PN}3-${PV}"
+DESCRIPTION="Reads XML configuration files to provide initialization of various Java objects within the system."
+HOMEPAGE="http://commons.apache.org/digester/"
+SRC_URI="mirror://apache/commons/digester/source/${MY_P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/commons-beanutils:1.7
+ dev-java/cglib:2.2
+ dev-java/commons-logging:0"
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/junit:4
+ dev-java/ant-junit
+ )
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="commons-beanutils-1.7 cglib-2.2 commons-logging"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven-build.xml build.xml || die
+}
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
+
+src_test() {
+ #TODO: not all tests are passed; investigate why.
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${MY_P}.jar" ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt || die
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+ use examples && java-pkg_doexamples src/examples
+}
diff --git a/dev-java/commons-digester/files/commons-digester-3.2_maven-build.xml b/dev-java/commons-digester/files/commons-digester-3.2_maven-build.xml
new file mode 100644
index 0000000..ad8de1a
--- /dev/null
+++ b/dev-java/commons-digester/files/commons-digester-3.2_maven-build.xml
@@ -0,0 +1,338 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 8/18/12 12:50 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-digester3-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-digester3-3.2"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.resourceDir.1" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/cglib/cglib/2.2.2/cglib-2.2.2.jar"/>
+ <pathelement location="${maven.repo.local}/asm/asm/3.3.1/asm-3.3.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-beanutils/commons-beanutils/1.8.3/commons-beanutils-1.8.3.jar"/>
+ <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/cglib/cglib/2.2.2/cglib-2.2.2.jar"/>
+ <pathelement location="${maven.repo.local}/asm/asm/3.3.1/asm-3.3.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-beanutils/commons-beanutils/1.8.3/commons-beanutils-1.8.3.jar"/>
+ <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="**/*.dtd"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/TestBean.java"/>
+ <exclude name="**/TestRule.java"/>
+ <exclude name="**/TestRuleSet.java"/>
+ <exclude name="**/Test*$*.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/TestBean.java"/>
+ <exclude name="**/TestRule.java"/>
+ <exclude name="**/TestRuleSet.java"/>
+ <exclude name="**/Test*$*.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ <link href="http://commons.apache.org/beanutils/v1.8.3/apidocs/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/cglib/cglib/2.2.2"/>
+ <get src="http://repository.apache.org/snapshots/cglib/cglib/2.2.2/cglib-2.2.2.jar"
+ dest="${maven.repo.local}/cglib/cglib/2.2.2/cglib-2.2.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/cglib/cglib/2.2.2/cglib-2.2.2.jar"
+ dest="${maven.repo.local}/cglib/cglib/2.2.2/cglib-2.2.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/asm/asm/3.3.1"/>
+ <get src="http://repository.apache.org/snapshots/asm/asm/3.3.1/asm-3.3.1.jar"
+ dest="${maven.repo.local}/asm/asm/3.3.1/asm-3.3.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/asm/asm/3.3.1/asm-3.3.1.jar"
+ dest="${maven.repo.local}/asm/asm/3.3.1/asm-3.3.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/commons-beanutils/commons-beanutils/1.8.3"/>
+ <get src="http://repository.apache.org/snapshots/commons-beanutils/commons-beanutils/1.8.3/commons-beanutils-1.8.3.jar"
+ dest="${maven.repo.local}/commons-beanutils/commons-beanutils/1.8.3/commons-beanutils-1.8.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/commons-beanutils/commons-beanutils/1.8.3/commons-beanutils-1.8.3.jar"
+ dest="${maven.repo.local}/commons-beanutils/commons-beanutils/1.8.3/commons-beanutils-1.8.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/commons-logging/commons-logging/1.1.1"/>
+ <get src="http://repository.apache.org/snapshots/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ dest="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ dest="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.10"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
+ <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/commons-digester/metadata.xml b/dev-java/commons-digester/metadata.xml
new file mode 100644
index 0000000..80859ae
--- /dev/null
+++ b/dev-java/commons-digester/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>the.dmol@gmail.com</email>
+ </maintainer>
+</pkgmetadata>