summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapysdr')
-rw-r--r--net-wireless/soapysdr/Manifest4
-rw-r--r--net-wireless/soapysdr/metadata.xml12
-rw-r--r--net-wireless/soapysdr/soapysdr-0.6.0.ebuild77
-rw-r--r--net-wireless/soapysdr/soapysdr-9999.ebuild77
4 files changed, 170 insertions, 0 deletions
diff --git a/net-wireless/soapysdr/Manifest b/net-wireless/soapysdr/Manifest
new file mode 100644
index 0000000..9a46974
--- /dev/null
+++ b/net-wireless/soapysdr/Manifest
@@ -0,0 +1,4 @@
+DIST soapysdr-0.6.0.tar.gz 112061 SHA256 54b0f84edbd52a10073444d9124f41b622194744d136ea77e25c8b883e65abf9 SHA512 19b65c4d8c052ed40ff22c27511bb3b366a1912cb07930cbfe21808edc67b1fd6d10c96cd597dca988f8a2bff3611bb8345432d91d55032daeeba700cf1303d1 WHIRLPOOL 926b2f22496a201d497832e3b199013072b5779cbdec8f07b0c29242b73196ba8852eabee93f90b4d582c6e7b2817215db08c26e24fa9b1709d8dab44c3757be
+EBUILD soapysdr-0.6.0.ebuild 1582 SHA256 d492e4f5a7f302f85cb63373538e51d9b59ceb7866a48b207f73cb0041d4fda1 SHA512 f4c9273ab5ab9e0fe2244d2a5b64ad8e399c69041e420ca72fb2a76b894f6206afe5493fbe78a7d68866a2a9645640a8b11cef5427da7b04eeab183a3c529cd5 WHIRLPOOL 3630c7a6c9fdeb107b72784febfb3e030ebb943628ce6f8f300a62a3ce3f3af522389bda664740f9aa78d48e48d490cfb93e196044191421493ac70d0204e245
+EBUILD soapysdr-9999.ebuild 1582 SHA256 d492e4f5a7f302f85cb63373538e51d9b59ceb7866a48b207f73cb0041d4fda1 SHA512 f4c9273ab5ab9e0fe2244d2a5b64ad8e399c69041e420ca72fb2a76b894f6206afe5493fbe78a7d68866a2a9645640a8b11cef5427da7b04eeab183a3c529cd5 WHIRLPOOL 3630c7a6c9fdeb107b72784febfb3e030ebb943628ce6f8f300a62a3ce3f3af522389bda664740f9aa78d48e48d490cfb93e196044191421493ac70d0204e245
+MISC metadata.xml 509 SHA256 fa22b66b9a52dcbec22b555c0104331e7e3a390c71f50c897ba67a042ba8ab58 SHA512 aba5caf0e9660cd0ad119c053deaea91113ad20293e7a7151d7b881d7fd25aa2707bd0dfa8a114560edefddadb024c690c23aae98dfb165947e5029345b3b8f3 WHIRLPOOL 03459452c72b5a9bc1a647c7cf0d751acec985d9f2c465ce7c2cc945590a71d31d7a50d431a5305669b480983290460171d40a5a37d4b43e359d966c37b0e73f
diff --git a/net-wireless/soapysdr/metadata.xml b/net-wireless/soapysdr/metadata.xml
new file mode 100644
index 0000000..2bc550c
--- /dev/null
+++ b/net-wireless/soapysdr/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andy@ndyk.de</email>
+ <name>Andrew Karpow</name>
+ </maintainer>
+ <longdescription lang="en">
+SoapySDR is an open-source generalized C/C++ API and runtime library for interfacing with SDR devices. With SoapySDR, you can instantiate, configure, and stream with an SDR device in a variety of environments.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/net-wireless/soapysdr/soapysdr-0.6.0.ebuild b/net-wireless/soapysdr/soapysdr-0.6.0.ebuild
new file mode 100644
index 0000000..9d12b1a
--- /dev/null
+++ b/net-wireless/soapysdr/soapysdr-0.6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="vendor and platform neutral SDR support library"
+HOMEPAGE="http://github.com/pothosware/SoapySDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig:0 )
+"
+
+src_prepare() {
+ eapply_user
+ use python && python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DENABLE_PYTHON=$(usex python)
+ )
+ if python_is_python3; then
+ mycmakeargs+=( -DBUILD_PYTHON3=ON
+ -DENABLE_PYTHON3=ON
+ )
+ else
+ mycmakeargs+=( -DBUILD_PYTHON3=OFF
+ -DENABLE_PYTHON3=OFF
+ )
+ fi
+
+ cmake-utils_src_configure
+ }
+ if use python; then
+ python_foreach_impl configuration
+ else
+ configuration
+ fi
+}
+
+src_compile() {
+ compilation() {
+ cmake-utils_src_make
+ }
+ use python && python_foreach_impl compilation || compilation
+}
+
+src_install() {
+ installation() {
+ cmake-utils_src_install DESTDIR="${ED}"
+ use python && python_optimize
+ }
+ use python && python_foreach_impl installation || installation
+}
diff --git a/net-wireless/soapysdr/soapysdr-9999.ebuild b/net-wireless/soapysdr/soapysdr-9999.ebuild
new file mode 100644
index 0000000..9d12b1a
--- /dev/null
+++ b/net-wireless/soapysdr/soapysdr-9999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="vendor and platform neutral SDR support library"
+HOMEPAGE="http://github.com/pothosware/SoapySDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig:0 )
+"
+
+src_prepare() {
+ eapply_user
+ use python && python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DENABLE_PYTHON=$(usex python)
+ )
+ if python_is_python3; then
+ mycmakeargs+=( -DBUILD_PYTHON3=ON
+ -DENABLE_PYTHON3=ON
+ )
+ else
+ mycmakeargs+=( -DBUILD_PYTHON3=OFF
+ -DENABLE_PYTHON3=OFF
+ )
+ fi
+
+ cmake-utils_src_configure
+ }
+ if use python; then
+ python_foreach_impl configuration
+ else
+ configuration
+ fi
+}
+
+src_compile() {
+ compilation() {
+ cmake-utils_src_make
+ }
+ use python && python_foreach_impl compilation || compilation
+}
+
+src_install() {
+ installation() {
+ cmake-utils_src_install DESTDIR="${ED}"
+ use python && python_optimize
+ }
+ use python && python_foreach_impl installation || installation
+}