summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@mailbox.tu-berlin.de>2013-09-27 19:12:15 +0200
committerandy <andy@mailbox.tu-berlin.de>2013-09-27 19:12:15 +0200
commit6acb55ab96113ad6b1561f6935816d8e74e26ad8 (patch)
treea132b6896b85929171e381c029f9d4db59853230 /sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild
parentremoved old jlink ebuilds (diff)
downloadandy-6acb55ab96113ad6b1561f6935816d8e74e26ad8.tar.gz
andy-6acb55ab96113ad6b1561f6935816d8e74e26ad8.tar.bz2
andy-6acb55ab96113ad6b1561f6935816d8e74e26ad8.zip
added layout.conf, gcc-arm-embedded-bin
Diffstat (limited to 'sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild')
-rw-r--r--sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild b/sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild
index 2e93238..327033f 100644
--- a/sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild
+++ b/sys-devel/gcc-arm-embedded-bin/gcc-arm-embedded-bin-4.7_p20130916.ebuild
@@ -2,26 +2,33 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-DESCRIPTION="GNU Tools for ARM Embedded Processors"
-HOMEPAGE="https://launchpad.net/gcc-arm-embedded/+download"
+DESCRIPTION="Pre-built GNU toolchain from ARM Cortex-M & Cortex-R processors (Cortex-M0/M0+/M3/M4, Cortex-R4/R5/R7)."
+HOMEPAGE="https://launchpad.net/gcc-arm-embedded"
SRC_URI="https://launchpad.net/gcc-arm-embedded/4.7/4.7-2013-q3-update/+download/gcc-arm-none-eabi-4_7-2013q3-20130916-linux.tar.bz2"
LICENSE="BSD GPL GPL-2 LGPL-2 LGPL-3 MIT NEWLIB ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86 -*"
-IUSE=""
+IUSE="doc samples"
RESTRICT="strip binchecks"
DEPEND=""
-RDEPEND="${DEPEND}"
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs )"
S="${WORKDIR}"/gcc-arm-none-eabi-4_7-2013q3/
src_install() {
+ if ! use samples ; then
+ rm -rf "${S}"/share/gcc-arm-none-eabi/samples
+ fi
+ if ! use doc ; then
+ rm -rf "${S}"/share/doc
+ fi
+
dodir /opt/${PN}
- \cp -r "${S}"/* "${ED}"/opt/${PN}
+ cp -r "${S}"/* "${ED}"/opt/${PN} || die "cp failed"
fowners -R root:0 /opt/${PN}
local DEST=/opt/${PN}