aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2013-02-03 09:56:17 +0100
committerAstroFloyd <AstroFloyd@gmail.com>2013-02-03 09:56:17 +0100
commit9c8358a09d2c987ef7036060e841b015d28c655a (patch)
treefb353f906135bd0dbacc3f4d016b58ec9de3fef1 /dev-vcs
parentUpdating sci-astronomy/amuse: added sys-devel/gcc[cxx] dependency (diff)
downloadAstroFloyd-9c8358a09d2c987ef7036060e841b015d28c655a.tar.gz
AstroFloyd-9c8358a09d2c987ef7036060e841b015d28c655a.tar.bz2
AstroFloyd-9c8358a09d2c987ef7036060e841b015d28c655a.zip
Added ebuild for dev-vcs/gitstats
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitstats/ChangeLog26
-rw-r--r--dev-vcs/gitstats/gitstats-9999.ebuild43
-rw-r--r--dev-vcs/gitstats/metadata.xml5
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-vcs/gitstats/ChangeLog b/dev-vcs/gitstats/ChangeLog
new file mode 100644
index 0000000..1ebf899
--- /dev/null
+++ b/dev-vcs/gitstats/ChangeLog
@@ -0,0 +1,26 @@
+# ChangeLog for dev-vcs/gitstats
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/ChangeLog,v 1.3 2011/09/21 08:25:56 mgorny Exp $
+
+ 03 Feb 2013; AstroFloyd <AstroFloyd@gmail.com> +gitstats-9999.ebuild,
+ +metadata.xml:
+ Updated urls of git repos
+
+ 03 Feb 2013; AstroFloyd <AstroFloyd@gmail.com> +gitstats-9999.ebuild,
+ +metadata.xml:
+ Updated urls of git repos
+
+ 21 Sep 2011; Michał Górny <mgorny@gentoo.org> gitstats-9999.ebuild:
+ Migrate to git-2.
+
+ 23 Jul 2010; Justin Lecher <jlec@gentoo.org> gitstats-9999.ebuild,
+ gitstats-100711.ebuild:
+ Last fix for Parhon ABIS, 329485
+
+*gitstats-100711 (11 Jul 2010)
+*gitstats-9999 (11 Jul 2010)
+
+ 11 Jul 2010; Justin Lecher <jlec@gentoo.org> +gitstats-9999.ebuild,
+ +gitstats-100711.ebuild, +metadata.xml:
+ Import from sunrise
+
diff --git a/dev-vcs/gitstats/gitstats-9999.ebuild b/dev-vcs/gitstats/gitstats-9999.ebuild
new file mode 100644
index 0000000..9d4f804
--- /dev/null
+++ b/dev-vcs/gitstats/gitstats-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-9999.ebuild,v 1.3 2011/09/21 08:25:56 mgorny Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+
+inherit python git-2
+
+DESCRIPTION="Statistics generator for git"
+HOMEPAGE="http://gitstats.sourceforge.net/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/hoxu/${PN}.git
+ http://repo.or.cz/w/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-visualization/gnuplot[gd]
+ dev-vcs/git"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ sed "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '/usr/share/gitstats':g" \
+ -i gitstats || die "failed to fix static files path"
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr VERSION="${PV}" install || die
+ dodoc doc/{README,*.txt} || die "doc install failed"
+}
diff --git a/dev-vcs/gitstats/metadata.xml b/dev-vcs/gitstats/metadata.xml
new file mode 100644
index 0000000..c1e2e62
--- /dev/null
+++ b/dev-vcs/gitstats/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>jlec@gentoo.org</email></maintainer>
+</pkgmetadata>