summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'nektoo.txt')
-rw-r--r--nektoo.txt66
1 files changed, 1 insertions, 65 deletions
diff --git a/nektoo.txt b/nektoo.txt
index b24fb64d3017..3fb53900ce91 100644
--- a/nektoo.txt
+++ b/nektoo.txt
@@ -54,68 +54,4 @@ WARNING:pkgcore:EAPI 7 isn't fully supported
* Working directory: '/usr/lib64/pkgcore/ebd'
received unknown com: CATEGORY='games-action' PKGCORE_EBUILD_PHASE_FUNC=true PKGCORE_ECONF_DISABLE_SILENT_RULES=true PKGCORE_ECONF_DISABLE_DEPENDENCY_TRACKING=true PKGCORE_UNPACK_CASE_INSENSITIVE=false PKGCORE_DODOC_ALLOW_RECURSIVE=true PKGCORE_UNPACK_ABSOLUTE_PATHS=false P='minetest-0.4.12' PKGCORE_BASH_COMPAT='3.2' PVR='0.4.12' PV='0.4.12' PKGCORE_DOINS_ALLOW_SYMLINKS=true PKGCORE_NEW_READS_STDIN=true PKGCORE_NONFATAL=false PR=r0 EAPI=5 PKGCORE_DOMAN_LANGUAGE_OVERRIDE=true PKGCORE_PROFILE_IUSE_INJECTION=true PKGCORE_NONFATAL_DIE=false EBUILD='/var/lib/repo-mirror-ci/repos/nektoo/games-action/minetest/minetest-0.4.12.ebuild' PF='minetest-0.4.12' PKGCORE_GLOBAL_FAILGLOB=false PN=minetest PKGCORE_ECONF_DOCDIR_AND_HTMLDIR=false PKGCORE_DOMAN_LANGUAGE_DETECT=truepath
!!! caught exception False while processing ebuild src: games-action/minetest-0.4.12
- * ERROR: net-p2p/i2p-messenger-0.2.24 failed (depend phase):
- * inherit for qt4-r2 failed
- *
- * Call stack:
- * isolated-functions.lib, line 354: called source '/var/lib/repo-mirror-ci/repos/nektoo/net-p2p/i2p-messenger/i2p-messenger-0.2.24.ebuild'
- * i2p-messenger-0.2.24.ebuild, line 23: called inherit 'eutils' 'qt4-r2'
- * ebuild-default-functions.lib, line 201: called __internal_inherit 'qt4-r2'
- * ebuild-daemon.lib, line 83: called die
- *
- * Working directory: '/usr/lib64/pkgcore/ebd'
-sandbox:stop caught signal 15 in pid 17783
-Sandboxed process killed by signal: Terminated
-Unhandled exception occurred:
-Traceback follows:
- File "/usr/lib64/python2.7/site-packages/snakeoil/cli/tool.py", line 132, in main
- exitstatus = func(self.options, self.out, self.err)
- File "/usr/lib64/python2.7/site-packages/pkgcore/scripts/pmaint.py", line 318, in regen_main
- ret.append(update_use_local_desc(repo, out, err))
- File "/usr/lib64/python2.7/site-packages/pkgcore/scripts/pmaint.py", line 190, in update_use_local_desc
- for p in repo:
- File "/usr/lib64/python2.7/site-packages/pkgcore/repository/configured.py", line 62, in <genexpr>
- return (x for x in self.raw_repo.itermatch(restrict, **kwds)
- File "/usr/lib64/python2.7/site-packages/pkgcore/repository/prototype.py", line 283, in _internal_match
- pkg = pkg_klass_override(pkg)
- File "/usr/lib64/python2.7/site-packages/pkgcore/repository/configured.py", line 50, in package_class
- return self._klass(pkg, **self._get_pkg_kwds(pkg))
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/repository.py", line 709, in _get_pkg_kwds
- immutable, enabled, disabled = self._get_pkg_use(pkg)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/domain.py", line 515, in get_package_use_unconfigured
- pre_defaults = [x[1:] for x in pkg.iuse if x[0] == '+']
- File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 98, in dynamic_getattr_dict
- raise_from(MetadataException(self, attr, str(e)))
- File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 90, in dynamic_getattr_dict
- val = functor(self)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 234, in <lambda>
- imap(intern, s.data.pop("IUSE", "").split()))
- File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 100, in dynamic_getattr_dict
- raise_from(MetadataException(self, attr, str(e)))
- File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 90, in dynamic_getattr_dict
- val = functor(self)
- File "/usr/lib64/python2.7/site-packages/pkgcore/package/metadata.py", line 59, in _get_data
- return self._fetch_metadata()
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 295, in _fetch_metadata
- return self._parent._get_metadata(self, ebp=ebp, force_regen=force_regen)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 384, in _get_metadata
- return self._update_metadata(pkg, ebp=ebp)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 392, in _update_metadata
- mydata = my_proc.get_keys(pkg, self._ecache)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/processor.py", line 811, in get_keys
- {"key": receive_key})
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/processor.py", line 751, in _run_depend_like_phase
- val = self.generic_handler(additional_commands=commands)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/processor.py", line 874, in generic_handler
- handlers[cmd](self, *args)
- File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/processor.py", line 899, in inherit_handler
- "inherit requires an unknown eclass, %s cannot be found" % line)
-
-MetadataException:
- metadata exception: pkg ebuild src: net-p2p/i2p-messenger-0.2.24, attr iuse
- error: metadata exception: pkg ebuild src: net-p2p/i2p-messenger-0.2.24, attr data
- error: inherit requires an unknown eclass, qt4-r2 cannot be found
- metadata exception: pkg ebuild src: net-p2p/i2p-messenger-0.2.24, attr data
- error: inherit requires an unknown eclass, qt4-r2 cannot be found
- inherit requires an unknown eclass, qt4-r2 cannot be found
- * Cache regen failed with 246
+ * Cache regen failed with -13