summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-11-02 11:09:06 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-11-02 11:24:37 -0700
commitf3b453ffaa6d1484462c2b4e78a542fc4a056b40 (patch)
tree29182db5b01e6a1e919f7d034b7022324fbc4ff0
parentnet-p2p/p2pool: add 9999 (diff)
downloadjohnmh-f3b453ffaa6d1484462c2b4e78a542fc4a056b40.tar.gz
johnmh-f3b453ffaa6d1484462c2b4e78a542fc4a056b40.tar.bz2
johnmh-f3b453ffaa6d1484462c2b4e78a542fc4a056b40.zip
net-p2p/xmrig-proxy: new package, add 6.22.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
-rw-r--r--net-p2p/xmrig-proxy/Manifest3
-rw-r--r--net-p2p/xmrig-proxy/metadata.xml11
-rw-r--r--net-p2p/xmrig-proxy/xmrig-proxy-6.22.0.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/net-p2p/xmrig-proxy/Manifest b/net-p2p/xmrig-proxy/Manifest
new file mode 100644
index 0000000..ab32b66
--- /dev/null
+++ b/net-p2p/xmrig-proxy/Manifest
@@ -0,0 +1,3 @@
+DIST xmrig-proxy-6.22.0.tar.gz 574602 BLAKE2B c732e6a7db648752d118222a84e7127105c4262b13ca5dceaf8ac4feb12838190ff49a26d8e791450803ccfa5fab9a300e84c3f03d0ba558aaa7e1d49d468753 SHA512 0050ec1faac22312f177f99c1ed45f29c2d74992acd911f970d3c3caee57cedab755940c37d2e97453b4230bab27197759e85613879d7e91fb804b52e43ca1cc
+EBUILD xmrig-proxy-6.22.0.ebuild 777 BLAKE2B 1fa7b4b01110fad6d70da40afd05612450c3272d0ff3b15a170ee81216b2fa1f61061fbbc128c46e91ebdbcd29fdca9cd7592fc915f2309e675679d83b3ad98c SHA512 e836161a52f53e17e9bb3c1d5d332525e2072a9b2e365abdc1b5dbe2d09ab2d4960f4c839b6b983edffc7350430d9a2de4cd2b6cfaee294571ec590748c946d3
+MISC metadata.xml 344 BLAKE2B 277052c92fe5ed2b0a41527ae0bcc2218a524190d1917e13a755d4b87c19b13f9353e47d45989e33ac83f2bf9c240e5394113d4b99a6fea13b55fb1206f36d78 SHA512 4dab40f1ce4e0ca00bfdcf506b787bf0af80b9c069f75803ecda5df1ce7a711fb30d11733d500559dc3752466c26cc166d6c9f7c7f4732a1c70cbaa08e4d7a58
diff --git a/net-p2p/xmrig-proxy/metadata.xml b/net-p2p/xmrig-proxy/metadata.xml
new file mode 100644
index 0000000..aca873a
--- /dev/null
+++ b/net-p2p/xmrig-proxy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xmrig/xmrig-proxy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/xmrig-proxy/xmrig-proxy-6.22.0.ebuild b/net-p2p/xmrig-proxy/xmrig-proxy-6.22.0.ebuild
new file mode 100644
index 0000000..574a67d
--- /dev/null
+++ b/net-p2p/xmrig-proxy/xmrig-proxy-6.22.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Monero (XMR) Stratum protocol proxy"
+HOMEPAGE="https://xmrig.com https://github.com/xmrig/xmrig-proxy"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/xmrig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="Apache-2.0 GPL-3+ MIT"
+SLOT="0"
+IUSE="+ssl"
+
+DEPEND="
+ dev-libs/libuv:=
+ ssl? ( dev-libs/openssl:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_TLS=$(usex ssl)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ default
+ dobin "${BUILD_DIR}/xmrig-proxy"
+}