aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/onedrive/onedrive-2.4.25-r1.ebuild')
-rw-r--r--net-misc/onedrive/onedrive-2.4.25-r1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-misc/onedrive/onedrive-2.4.25-r1.ebuild b/net-misc/onedrive/onedrive-2.4.25-r1.ebuild
index b88b785..14fa9e7 100644
--- a/net-misc/onedrive/onedrive-2.4.25-r1.ebuild
+++ b/net-misc/onedrive/onedrive-2.4.25-r1.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+DLANG_COMPAT=( dmd-2_{106..109} ldc2-1_{35..39} )
+inherit bash-completion-r1 dlang-single systemd
+
DESCRIPTION="Free Client for OneDrive on Linux"
HOMEPAGE="https://abraunegg.github.io/"
SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
@@ -10,11 +13,9 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# no straight forward way to run unittests. Probably need to do DFLAGS=-unittest econf
IUSE="debug libnotify"
-
-DLANG_COMPAT=( dmd-2_{106..108} ldc2-1_{35..38} )
-
-inherit dlang-single systemd bash-completion-r1
+RESTRICT=test
REQUIRED_USE=${DLANG_REQUIRED_USE}
RDEPEND="
@@ -55,8 +56,4 @@ pkg_postinst() {
elog "OneDrive Free Client needs to be authorized to access your data before the"
elog "first use. To do so, run onedrive in a terminal for the user in question and"
elog "follow the steps on screen."
- elog
- ewarn "When upgrading from 2.3 you are required to reauthorise your client."
- ewarn "This is due to changing the client identifier to assist with resolving"
- ewarn "the correct handling of 429 error responses (activityLimitReached)"
}