aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-03-09 19:46:11 +0100
committerMarco Leise <marco.leise@gmx.de>2020-03-09 19:46:11 +0100
commit77608c2c78588a7660212a0e1d293706516274f3 (patch)
treed3a4be6bcf1403808d6fd82ff40527f592712a91 /dev-util
parentdmd-2.091.0 & dub-1.20.0 (diff)
downloaddlang-77608c2c78588a7660212a0e1d293706516274f3.tar.gz
dlang-77608c2c78588a7660212a0e1d293706516274f3.tar.bz2
dlang-77608c2c78588a7660212a0e1d293706516274f3.zip
replaced own forks of GCC ebuilds with system-wide ebuild
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gdmd/Manifest2
-rw-r--r--dev-util/gdmd/files/gdmd-no-dmd-conf.patch12
-rw-r--r--dev-util/gdmd/gdmd-6.4.0.ebuild33
-rw-r--r--dev-util/gdmd/gdmd-7.3.0.ebuild33
-rw-r--r--dev-util/gdmd/gdmd-9.2.0.ebuild27
5 files changed, 40 insertions, 67 deletions
diff --git a/dev-util/gdmd/Manifest b/dev-util/gdmd/Manifest
index 0f35556..0866ade 100644
--- a/dev-util/gdmd/Manifest
+++ b/dev-util/gdmd/Manifest
@@ -1 +1 @@
-DIST gdmd-2.068.2.tar.gz 23488 BLAKE2B 0add18bad42a7a2f562599af95acfbea9d57014eae4360754269fbedf7bbd869d4cd9eb9c00e8d9a0085a7c479fd5dadce1f1f413bbc5139f7c619691c81c118 SHA512 2614bd7ae116653368b44f33ddbb6f5690b0f28273e134129da19e98d71d5105386a901b647e68c6778c71f056ff4958433048e6db12f0a2895b5c8a39dad016
+DIST gdmd-0.1.0.tar.gz 7794 BLAKE2B f613c1faf7abb9f72990e21dfdf21e69f4d83fde5d7d6a8a0ccac16a21c0cf39f2d03b2fba7f9b19009b1e2198413c99653635a32cbad48bb8b5dfbf5da1ebab SHA512 54c1b56e252feb024d400a03df7d7b3e5942f98ce6542d77030659ec09bba3770426fc88e143550d24be8272dfa4ff510de8335badfbf9ae6e5f5b6063216fd3
diff --git a/dev-util/gdmd/files/gdmd-no-dmd-conf.patch b/dev-util/gdmd/files/gdmd-no-dmd-conf.patch
new file mode 100644
index 0000000..30f2a09
--- /dev/null
+++ b/dev-util/gdmd/files/gdmd-no-dmd-conf.patch
@@ -0,0 +1,12 @@
+--- a/dmd-script 2020-03-09 19:10:12.000000000 +0100
++++ b/dmd-script 2020-03-09 19:03:57.320213593 +0100
+@@ -307,9 +307,6 @@
+ exit 0;
+ }
+
+-# Load dmd.conf before before parsing arguments.
+-readINI();
+-
+ if ($ENV{DFLAGS}) {
+ push @ARGV, split /\s+/, $ENV{DFLAGS};
+ }
diff --git a/dev-util/gdmd/gdmd-6.4.0.ebuild b/dev-util/gdmd/gdmd-6.4.0.ebuild
deleted file mode 100644
index e80c596..0000000
--- a/dev-util/gdmd/gdmd-6.4.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Wrapper script for gdc that emulates the dmd command"
-HOMEPAGE="http://www.gdcproject.org/"
-LICENSE="GPL-3+"
-
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-DEPEND="=sys-devel/gcc-${PV}*[d]"
-RDEPEND="${DEPEND}"
-FRONTEND="2.068.2"
-SRC_URI="https://codeload.github.com/D-Programming-GDC/gdmd/tar.gz/v${FRONTEND} -> gdmd-${FRONTEND}.tar.gz"
-S="${WORKDIR}/GDMD-${FRONTEND}"
-
-DLANG_PACKAGE_TYPE="single"
-DLANG_USE_COMPILER="gdc-${PV}"
-
-inherit dlang
-
-d_src_compile() {
- local versions="GCC_49_Plus"
- dlang_compile_bin "gdmd" "src/main.d" "src/gdmd/*.d"
-}
-
-d_src_install() {
- local binPath="usr/${CHOST}/gcc-bin/${PV}"
- exeinto "${binPath}"
- newexe gdmd "${CHOST}-gdmd"
- ln -f "${D}${binPath}/${CHOST}-gdmd" "${D}${binPath}/gdmd" || die "Could not create 'gdmd' hardlink"
-}
diff --git a/dev-util/gdmd/gdmd-7.3.0.ebuild b/dev-util/gdmd/gdmd-7.3.0.ebuild
deleted file mode 100644
index 39ed4c7..0000000
--- a/dev-util/gdmd/gdmd-7.3.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Wrapper script for gdc that emulates the dmd command"
-HOMEPAGE="http://www.gdcproject.org/"
-LICENSE="GPL-3+"
-
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-macos"
-DEPEND="=sys-devel/gcc-${PV}*[d]"
-RDEPEND="${DEPEND}"
-FRONTEND="2.068.2"
-SRC_URI="https://codeload.github.com/D-Programming-GDC/gdmd/tar.gz/v${FRONTEND} -> gdmd-${FRONTEND}.tar.gz"
-S="${WORKDIR}/GDMD-${FRONTEND}"
-
-DLANG_PACKAGE_TYPE="single"
-DLANG_USE_COMPILER="gdc-${PV}"
-
-inherit dlang
-
-d_src_compile() {
- local versions="GCC_49_Plus"
- dlang_compile_bin "gdmd" "src/main.d" "src/gdmd/*.d"
-}
-
-d_src_install() {
- local binPath="usr/${CHOST}/gcc-bin/${PV}"
- exeinto "${binPath}"
- newexe gdmd "${CHOST}-gdmd"
- ln -f "${D}${binPath}/${CHOST}-gdmd" "${D}${binPath}/gdmd" || die "Could not create 'gdmd' hardlink"
-}
diff --git a/dev-util/gdmd/gdmd-9.2.0.ebuild b/dev-util/gdmd/gdmd-9.2.0.ebuild
new file mode 100644
index 0000000..0c66a62
--- /dev/null
+++ b/dev-util/gdmd/gdmd-9.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper script for gdc that emulates the dmd command"
+HOMEPAGE="http://www.gdcproject.org/"
+LICENSE="GPL-3+"
+
+SLOT="${PV}"
+KEYWORDS="amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-macos"
+RDEPEND="=sys-devel/gcc-${PV}*[d]"
+RELEASE="0.1.0"
+SRC_URI="https://codeload.github.com/D-Programming-GDC/gdmd/tar.gz/script-${RELEASE} -> gdmd-${RELEASE}.tar.gz"
+PATCHES="${FILESDIR}/${PN}-no-dmd-conf.patch"
+S="${WORKDIR}/gdmd-script-${RELEASE}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local binPath="usr/${CHOST}/gcc-bin/${PV}"
+ exeinto "${binPath}"
+ newexe dmd-script "${CHOST}-gdmd"
+ ln -f "${D}/${binPath}/${CHOST}-gdmd" "${D}/${binPath}/gdmd" || die "Could not create 'gdmd' hardlink"
+}