aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-12-31 16:17:34 +0100
committerMarco Leise <marco.leise@gmx.de>2020-12-31 16:17:34 +0100
commit4bfe706d5028ce27407e34c8f0fbee9b73bb70cc (patch)
tree7f5f65752bcb543eb6014d1bdf337fb2452dbb18 /dev-util/dfmt
parentsome dmd versions don't compile with frontend 2.092 as host compiler, these h... (diff)
downloaddlang-4bfe706d5028ce27407e34c8f0fbee9b73bb70cc.tar.gz
dlang-4bfe706d5028ce27407e34c8f0fbee9b73bb70cc.tar.bz2
dlang-4bfe706d5028ce27407e34c8f0fbee9b73bb70cc.zip
stabilization sweep
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'dev-util/dfmt')
-rw-r--r--dev-util/dfmt/Manifest1
-rw-r--r--dev-util/dfmt/dfmt-0.13.0.ebuild58
-rw-r--r--dev-util/dfmt/dfmt-0.13.2.ebuild2
3 files changed, 1 insertions, 60 deletions
diff --git a/dev-util/dfmt/Manifest b/dev-util/dfmt/Manifest
index c543abb..8948644 100644
--- a/dev-util/dfmt/Manifest
+++ b/dev-util/dfmt/Manifest
@@ -1,4 +1,3 @@
-DIST dfmt-0.13.0.tar.gz 90119 BLAKE2B f47d0a661b8b9c571766e017cf50fc8dcbe0d0a05efc62ddb36734013986d2244d76e4977dc4893d036e297f20c818780d76ea75232168d7a652b0ba8067316f SHA512 1cea004218dc49f9c7079cc2063fccac8b9c97b9683929f2abde6aceedf1f3ad35009fd3978affaf5d33f8779918e9fcf9084a91ba21c87680a25d33bc6bc8ca
DIST dfmt-0.13.2.tar.gz 91926 BLAKE2B 0d02600f10143232c62deca8f34ed239bb2e54f0390388aad184d3d78bd39aae5724d22f59d1303a9837173933dd8ca448aedeccb839fdd413ce827199202c35 SHA512 a1fb8339da4201d114bfc3748df2d1b4f42505932b1e55f74daa096cf48e91df827c677c7cc1c7df27937e45cebf571cb57551e843261915567e37cf4f3c8f29
DIST libdparse-1557eb079a2d5958e0a7136f942eea0922d58e8a.tar.gz 132387 BLAKE2B 180316ef25713eb723e43e13c983f2c7b8c775f7e4c984217b497505ed0f7a9b1eb351867317a1e0957dd368a71b7fe403d8a636baf8ad8240f2b39fb7bc2c69 SHA512 1dbab30db4f14d99f27672be12b63bba04534a0c69c58453441b8a654336d9a38c869a6db738442b692d4d7cfdb0f68ed0bfaaa462c58aed0bedef60ea4dfbac
DIST stdx-allocator-ae237cabd1843774cc78aad0729c914a3dd579db.tar.gz 103650 BLAKE2B 8d03c2dc76194b18da92261c533c402b87bda1964662070d02ceacbab3dda91a834c0c8bfe45feb1d9a3d7669f96a2a1f7b9a6b7eff7ea53069480d8de8fe15e SHA512 893e5ecefac86a64b3a91f034cc9f42aabc264d111b40accf890b505ec9d077fcaac0b29fc202400448994e4ff021263beef7716798734cb9b71b6aad1aaf394
diff --git a/dev-util/dfmt/dfmt-0.13.0.ebuild b/dev-util/dfmt/dfmt-0.13.0.ebuild
deleted file mode 100644
index 7163273..0000000
--- a/dev-util/dfmt/dfmt-0.13.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Dfmt is a formatter for D source code"
-HOMEPAGE="https://github.com/dlang-community/dfmt"
-LICENSE="Boost-1.0"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-LIBDPARSE="1557eb079a2d5958e0a7136f942eea0922d58e8a"
-ALLOCATOR="ae237cabd1843774cc78aad0729c914a3dd579db"
-SRC_URI="
- https://github.com/dlang-community/dfmt/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz
- https://github.com/dlang-community/libdparse/archive/${LIBDPARSE}.tar.gz -> libdparse-${LIBDPARSE}.tar.gz
- https://github.com/dlang-community/stdx-allocator/archive/${ALLOCATOR}.tar.gz -> stdx-allocator-${ALLOCATOR}.tar.gz
- "
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang bash-completion-r1
-
-src_prepare() {
- mkdir bin || die "Failed to create 'bin' directory."
- cat > bin/githash.txt << EOF
-v${PV}
-EOF
- dlang_src_prepare
-}
-
-d_src_compile() {
- local libdparse_src="../libdparse-${LIBDPARSE}/src"
- local allocator_src="../stdx-allocator-${ALLOCATOR}/source"
- local imports="src ${libdparse_src} ${allocator_src}"
- local string_imports="bin"
-
- dlang_compile_bin "bin/dfmt" "src/dfmt/main.d" "src/dfmt/config.d" "src/dfmt/editorconfig.d" \
- "src/dfmt/ast_info.d" "src/dfmt/indentation.d" "src/dfmt/tokens.d" "src/dfmt/wrapping.d" \
- "src/dfmt/formatter.d" "src/dfmt/globmatch_editorconfig.d" \
- ${libdparse_src}/dparse/lexer.d ${libdparse_src}/dparse/parser.d ${libdparse_src}/dparse/ast.d \
- ${libdparse_src}/dparse/rollback_allocator.d ${libdparse_src}/dparse/stack_buffer.d \
- ${libdparse_src}/dparse/trivia.d ${libdparse_src}/std/experimental/lexer.d \
- ${allocator_src}/stdx/allocator/common.d ${allocator_src}/stdx/allocator/internal.d \
- ${allocator_src}/stdx/allocator/mallocator.d ${allocator_src}/stdx/allocator/package.d \
- ${allocator_src}/stdx/allocator/gc_allocator.d ${allocator_src}/stdx/allocator/typed.d
-}
-
-d_src_test() {
- cd tests && ./test.sh
-}
-
-d_src_install() {
- dobin bin/dfmt
- dodoc README.md LICENSE.txt
- dobashcomp bash-completion/completions/dfmt
-}
diff --git a/dev-util/dfmt/dfmt-0.13.2.ebuild b/dev-util/dfmt/dfmt-0.13.2.ebuild
index 50ab11e..7163273 100644
--- a/dev-util/dfmt/dfmt-0.13.2.ebuild
+++ b/dev-util/dfmt/dfmt-0.13.2.ebuild
@@ -8,7 +8,7 @@ HOMEPAGE="https://github.com/dlang-community/dfmt"
LICENSE="Boost-1.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
LIBDPARSE="1557eb079a2d5958e0a7136f942eea0922d58e8a"
ALLOCATOR="ae237cabd1843774cc78aad0729c914a3dd579db"
SRC_URI="