aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2018-06-22 23:31:48 -0500
committerILMostro <ilmostro7@gmail.com>2018-06-22 23:31:48 -0500
commitaa3b462be2ea1d91bf05c89ed5157569fd7230f1 (patch)
treeb810c34ce21c6011c2d1fadb2107755b732c4fb1 /sys-auth/ykpers/ykpers-1.18.1.ebuild
parentnet-libs/zeromq asciidoc --> asciidoctor (diff)
downloadag-ops-aa3b462be2ea1d91bf05c89ed5157569fd7230f1.tar.gz
ag-ops-aa3b462be2ea1d91bf05c89ed5157569fd7230f1.tar.bz2
ag-ops-aa3b462be2ea1d91bf05c89ed5157569fd7230f1.zip
sys-auth/ykpers asciidoc --> asciidoctor
Diffstat (limited to 'sys-auth/ykpers/ykpers-1.18.1.ebuild')
-rw-r--r--sys-auth/ykpers/ykpers-1.18.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ykpers-1.18.1.ebuild b/sys-auth/ykpers/ykpers-1.18.1.ebuild
new file mode 100644
index 0000000..079b08b
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.18.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ dev-ruby/asciidoctor
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use consolekit && udev_dorules *.rules
+
+ find "${D}" -name '*.la' -delete || die
+}