summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/powerstat/powerstat-9999.ebuild')
-rw-r--r--sys-power/powerstat/powerstat-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-power/powerstat/powerstat-9999.ebuild b/sys-power/powerstat/powerstat-9999.ebuild
index 0f707208abf8..a4538d1cb047 100644
--- a/sys-power/powerstat/powerstat-9999.ebuild
+++ b/sys-power/powerstat/powerstat-9999.ebuild
@@ -3,11 +3,12 @@
EAPI=8
-inherit git-r3 toolchain-funcs
+EGIT_REPO_URI="https://github.com/ColinIanKing/${PN}.git"
+
+inherit bash-completion-r1 git-r3 toolchain-funcs
DESCRIPTION="Laptop power measuring tool"
HOMEPAGE="https://launchpad.net/ubuntu/+source/powerstat https://github.com/ColinIanKing/powerstat"
-EGIT_REPO_URI="https://github.com/ColinIanKing/${PN}.git"
LICENSE="GPL-2+"
SLOT="0"
@@ -15,12 +16,18 @@ SLOT="0"
src_prepare() {
default
- # Don't compress manpages
+ # Don't compress manpages, respect CFLAGS
sed -i -e '/install:/s/ powerstat.8.gz//' \
-e '/cp powerstat.8/s/.gz//' \
+ -e '/CFLAGS += -Wall/s| -O2||' \
Makefile || die "sed failed"
}
src_compile() {
emake CC="$(tc-getCC)"
}
+
+src_install() {
+ default
+ dobashcomp bash-completion/powerstat
+}