summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-common/fuse-common-3.10.4.ebuild4
-rw-r--r--sys-fs/fuse/fuse-2.9.9-r1.ebuild10
2 files changed, 3 insertions, 11 deletions
diff --git a/sys-fs/fuse-common/fuse-common-3.10.4.ebuild b/sys-fs/fuse-common/fuse-common-3.10.4.ebuild
index 8e3aff886fde..24670d1b7e68 100644
--- a/sys-fs/fuse-common/fuse-common-3.10.4.ebuild
+++ b/sys-fs/fuse-common/fuse-common-3.10.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,8 +23,6 @@ src_install() {
if use kernel_linux ; then
newinitd "${FILESDIR}"/fuse.init fuse
- elif use kernel_FreeBSD ; then
- newinitd "${FILESDIR}"/fuse-fbsd.init fuse
else
die "We don't know what init code install for your kernel, please file a bug."
fi
diff --git a/sys-fs/fuse/fuse-2.9.9-r1.ebuild b/sys-fs/fuse/fuse-2.9.9-r1.ebuild
index c8d15352dff6..927ab8b2c137 100644
--- a/sys-fs/fuse/fuse-2.9.9-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.9.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,9 +15,8 @@ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/iconv.m4.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples kernel_linux kernel_FreeBSD static-libs"
+IUSE="examples kernel_linux static-libs"
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
BDEPEND="virtual/pkgconfig"
RDEPEND=">=sys-fs/fuse-common-3.3.0-r1"
@@ -69,11 +68,6 @@ src_install() {
dodoc example/*
fi
- if use kernel_FreeBSD ; then
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- fi
-
find "${ED}" -name '*.la' -delete || die
# installed via fuse-common