summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/slibtool/slibtool-0.5.33.ebuild')
-rw-r--r--sys-devel/slibtool/slibtool-0.5.33.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/slibtool/slibtool-0.5.33.ebuild b/sys-devel/slibtool/slibtool-0.5.33.ebuild
new file mode 100644
index 000000000000..515a39ae78f4
--- /dev/null
+++ b/sys-devel/slibtool/slibtool-0.5.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+# git.foss21.org is the official repository per upstream
+DESCRIPTION="A skinny libtool implementation, written in C"
+HOMEPAGE="https://git.foss21.org/slibtool"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.foss21.org/slibtool"
+else
+ SRC_URI="https://dl.midipix.org/slibtool/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ # Custom configure script (not generated by autoconf)
+ ./configure \
+ --compiler=$(tc-getCC) \
+ --host=${CHOST} \
+ --prefix="${EPREFIX}"/usr \
+ || die
+}