summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bpf-toolchain')
-rw-r--r--sys-devel/bpf-toolchain/bpf-toolchain-14.2.0-r2.ebuild (renamed from sys-devel/bpf-toolchain/bpf-toolchain-14.2.0-r1.ebuild)8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0-r1.ebuild b/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0-r2.ebuild
index 0c5a58f41988..093dcc4f54dd 100644
--- a/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0-r1.ebuild
+++ b/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0-r2.ebuild
@@ -203,6 +203,9 @@ src_install() {
}
pkg_postinst() {
+ use bin-symlinks && has_version dev-util/shadowman && [[ ! ${ROOT} ]] &&
+ eselect compiler-shadow update all
+
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Note that this package is primarily intended for DTrace, systemd, and related"
elog "packages to depend on without needing a manual crossdev setup."
@@ -212,3 +215,8 @@ pkg_postinst() {
elog " https://wiki.gentoo.org/wiki/Crossdev"
fi
}
+
+pkg_postrm() {
+ use bin-symlinks && has_version dev-util/shadowman && [[ ! ${ROOT} ]] &&
+ eselect compiler-shadow clean all
+}