summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hpx/hpx-9999.ebuild')
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index b440abe724f0..c7977e7361c5 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ else
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 multilib python-single-r1
+inherit cmake-utils fortran-2 multilib python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
@@ -38,14 +38,14 @@ DEPEND="${RDEPEND}
test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {