summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/geogebra')
-rw-r--r--sci-mathematics/geogebra/geogebra-5.0.339.0_p20170308-r1.ebuild (renamed from sci-mathematics/geogebra/geogebra-5.0.339.0_p20170308.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-mathematics/geogebra/geogebra-5.0.339.0_p20170308.ebuild b/sci-mathematics/geogebra/geogebra-5.0.339.0_p20170308-r1.ebuild
index 22c7ea2ca1a6..2ff4ab0b0843 100644
--- a/sci-mathematics/geogebra/geogebra-5.0.339.0_p20170308.ebuild
+++ b/sci-mathematics/geogebra/geogebra-5.0.339.0_p20170308-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils gnome2-utils xdg
+inherit eutils gnome2-utils xdg java-pkg-2
MY_COMMIT_HASH="7d5ac993d3f88f6701f56edbfe325d86afcaad87"
@@ -242,6 +242,7 @@ IUSE=""
RESTRICT="bindist"
DEPEND="dev-java/oracle-jdk-bin[javafx]
>=dev-java/gradle-bin-3.0"
+
# Requires oracle-jdk/jre-bin because there is no openjfx ebuild as of now
RDEPEND="|| (
dev-java/oracle-jre-bin[javafx]
@@ -250,6 +251,10 @@ RDEPEND="|| (
S="${WORKDIR}/${PN}-${MY_COMMIT_HASH}/"
+JAVA_PKG_WANT_BUILD_VM="oracle-jdk-bin-1.8"
+JAVA_PKG_WANT_SOURCE="1.8"
+JAVA_PKG_WANT_TARGET="1.8"
+
# Override the repositories with our local maven repository
# so that it doesn't attemp to fetch from the network
__set_gradle_repositories() {