summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild')
-rw-r--r--sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild b/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
new file mode 100644
index 000000000000..6e7af4ff9b2b
--- /dev/null
+++ b/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Cross conversion environment of NMR spectra"
+HOMEPAGE="http://fermi.pharm.hokudai.ac.jp/olivia/api/index.php/Xyza2pipe_src"
+SRC_URI="http://fermi.pharm.hokudai.ac.jp/olivia/documents/xyza2pipe.tgz -> ${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="olivia"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CC
+ mkdir bin
+}
+
+src_install() {
+ local i
+ dodoc README FEEDBACK
+ cd bin || die
+ for i in *; do
+ newbin ${i}{,-olivia}
+ done
+}