summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mira')
-rw-r--r--sci-biology/mira/files/mira-4.0.2-cmath.patch14
-rw-r--r--sci-biology/mira/mira-4.0.2.ebuild6
2 files changed, 18 insertions, 2 deletions
diff --git a/sci-biology/mira/files/mira-4.0.2-cmath.patch b/sci-biology/mira/files/mira-4.0.2-cmath.patch
new file mode 100644
index 000000000000..a4a020177af7
--- /dev/null
+++ b/sci-biology/mira/files/mira-4.0.2-cmath.patch
@@ -0,0 +1,14 @@
+--- mira-4.0.2/src/mira/ads.C
++++ mira-4.0.2/src/mira/ads.C
+@@ -31,10 +31,11 @@
+ * Routines for computing scores and some other classification number are
+ * provided, too.
+ *
+ */
+
++#include <cmath>
+
+ #include "ads.H"
+
+ #include "errorhandling/errorhandling.H"
+ #include "util/dptools.H"
diff --git a/sci-biology/mira/mira-4.0.2.ebuild b/sci-biology/mira/mira-4.0.2.ebuild
index 3814d2dbd749..758e30b28e36 100644
--- a/sci-biology/mira/mira-4.0.2.ebuild
+++ b/sci-biology/mira/mira-4.0.2.ebuild
@@ -41,7 +41,8 @@ src_prepare() {
find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
epatch \
"${FILESDIR}"/${PN}-3.4.0.2-boost-1.50.patch \
- "${FILESDIR}"/${P}-cout.patch
+ "${FILESDIR}"/${P}-cout.patch \
+ "${FILESDIR}"/${P}-cmath.patch
sed \
-e "s:-O[23]::g" \
@@ -50,9 +51,10 @@ src_prepare() {
eautoreconf
- # Remove C++ source files that were built with flex by upstream.
+ # Remove C++ source files that upstream built with flex.
local f
local PREBUILT_CXX_LEXER_FILES=(
+ "$S"/src/caf/caf_flexer.cc
"$S"/src/io/exp_flexer.cc
"$S"/src/mira/parameters_flexer.cc
)