summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/vpncwatch/vpncwatch-1.8.1-r1.ebuild')
-rw-r--r--net-vpn/vpncwatch/vpncwatch-1.8.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-vpn/vpncwatch/vpncwatch-1.8.1-r1.ebuild b/net-vpn/vpncwatch/vpncwatch-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..5f271c07ccee
--- /dev/null
+++ b/net-vpn/vpncwatch/vpncwatch-1.8.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Keepalive daemon for vpnc on Linux systems"
+HOMEPAGE="https://github.com/dcantrell/vpncwatch/"
+SRC_URI="https://github.com/downloads/dcantrell/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-vpn/vpnc"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}