summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/opendchub/files/opendchub-0.8.2-telnet.patch4
-rw-r--r--net-p2p/opendchub/opendchub-0.8.2.ebuild17
2 files changed, 10 insertions, 11 deletions
diff --git a/net-p2p/opendchub/files/opendchub-0.8.2-telnet.patch b/net-p2p/opendchub/files/opendchub-0.8.2-telnet.patch
index f81bf44cbc69..c8efc525ed65 100644
--- a/net-p2p/opendchub/files/opendchub-0.8.2-telnet.patch
+++ b/net-p2p/opendchub/files/opendchub-0.8.2-telnet.patch
@@ -1,5 +1,5 @@
---- opendchub-0.8.2/src/main.c.orig
-+++ opendchub-0.8.2/src/main.c
+--- a/src/main.c
++++ b/src/main.c
@@ -1073,7 +1073,7 @@
/* The chat command, starts with <nick> */
else if(*temp == '<')
diff --git a/net-p2p/opendchub/opendchub-0.8.2.ebuild b/net-p2p/opendchub/opendchub-0.8.2.ebuild
index 0e6df9059519..047e913aefc7 100644
--- a/net-p2p/opendchub/opendchub-0.8.2.ebuild
+++ b/net-p2p/opendchub/opendchub-0.8.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="hub software for Direct Connect"
HOMEPAGE="http://opendchub.sf.net"
@@ -17,34 +17,33 @@ IUSE="perl"
RDEPEND="perl? ( dev-lang/perl )"
DEPEND="${RDEPEND}"
-DOCS="NEWS TODO README AUTHORS Documentation/*"
+PATCHES=( "${FILESDIR}"/${P}-telnet.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-telnet.patch
+ default
eautoreconf
}
src_configure() {
- add-flags -fcommon
+ append-cflags -fcommon
use perl || myconf="--disable-perl --enable-switch_user"
econf ${myconf}
}
src_install() {
default
+ dodoc -r Documentation/.
- if use perl ; then
+ if use perl; then
dobin "${FILESDIR}"/opendchub_setup.sh
insinto /usr/share/opendchub/scripts
- doins Samplescripts/*
+ doins -r Samplescripts/.
fi
}
pkg_postinst() {
if use perl ; then
- echo
einfo "To set up perl scripts for opendchub to use, please run"
einfo "opendchub_setup.sh as the user you will be using opendchub as."
- echo
fi
}