summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/r8168/r8168-8.047.04.ebuild')
-rw-r--r--net-misc/r8168/r8168-8.047.04.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/net-misc/r8168/r8168-8.047.04.ebuild b/net-misc/r8168/r8168-8.047.04.ebuild
deleted file mode 100644
index 5d05429e616c..000000000000
--- a/net-misc/r8168/r8168-8.047.04.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info linux-mod eutils
-
-DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
-HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
-SRC_URI="${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="fetch"
-
-MODULE_NAMES="r8168(net:${S}/src)"
-BUILD_TARGETS="modules"
-
-CONFIG_CHECK="!R8169"
-ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
-
-pkg_nofetch() {
- einfo "Please download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "using the \"GBE Ethernet LINUX driver r8168 for kernel up to 4.15\" link."
-}
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERNELDIR=${KV_DIR}"
-}
-
-src_install() {
- linux-mod_src_install
- dodoc README
-}