summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mswatch')
-rw-r--r--net-mail/mswatch/Manifest1
-rw-r--r--net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch26
-rw-r--r--net-mail/mswatch/metadata.xml8
-rw-r--r--net-mail/mswatch/mswatch-1.2.0.ebuild33
4 files changed, 68 insertions, 0 deletions
diff --git a/net-mail/mswatch/Manifest b/net-mail/mswatch/Manifest
new file mode 100644
index 000000000000..29e96dec1960
--- /dev/null
+++ b/net-mail/mswatch/Manifest
@@ -0,0 +1 @@
+DIST mswatch-1.2.0.tar.gz 434986 SHA256 2623514442237e11c91a06ab406d9594669ddb70fd1d55b84371ea613e8ac1a7 SHA512 c6774993909cb066514cb0ceb163bfd5e023d357435c6779d2d049cc9d56a278d5502193af1f4f5d6af264ff041b43b6c0fe2c400f775e8c22ed395a183c75f9 WHIRLPOOL c5ce2269cbc73fb4e057261751ba43077c4cf4204033ce21bbfb80ede981476c5385080d4d07505c1d8a12812c758e0a573d477f3c5c6451126996bc5b758e35
diff --git a/net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch b/net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch
new file mode 100644
index 000000000000..c11052164c66
--- /dev/null
+++ b/net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch
@@ -0,0 +1,26 @@
+ https://bugs.gentoo.org/424673
+
+ src/lib/util.cc | 1 +
+ src/watch_maildirs/inotify/state.cc | 1 +
+ 2 files changed, 2 insertions(+)
+
+--- a/src/lib/util.cc
++++ b/src/lib/util.cc
+@@ -6,6 +6,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
++#include <unistd.h>
+
+ #include <sstream>
+ #include <string>
+--- a/src/watch_maildirs/inotify/state.cc
++++ b/src/watch_maildirs/inotify/state.cc
+@@ -1,6 +1,7 @@
+ #include <assert.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <unistd.h>
+
+ #include "lib/util.h"
+ #include "state.h"
diff --git a/net-mail/mswatch/metadata.xml b/net-mail/mswatch/metadata.xml
new file mode 100644
index 000000000000..b078c4f77d46
--- /dev/null
+++ b/net-mail/mswatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">mswatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/mswatch/mswatch-1.2.0.ebuild b/net-mail/mswatch/mswatch-1.2.0.ebuild
new file mode 100644
index 000000000000..42e9fb2b6b5e
--- /dev/null
+++ b/net-mail/mswatch/mswatch-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit linux-info autotools-utils
+
+DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
+HOMEPAGE="http://mswatch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2.6:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~INOTIFY_USER"
+ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
+
+DOCS=( AUTHORS NEWS README THANKS TODO )
+PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --with-notify=inotify
+ )
+ autotools-utils_src_configure
+}