summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3/nghttp3-9999.ebuild')
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 42309a43581b..9e1fdeb754e4 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~ppc64 ~riscv ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="HTTP/3 library written in C"
@@ -18,9 +18,9 @@ HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
LICENSE="MIT"
SLOT="0/0"
-
IUSE="static-libs test"
RESTRICT="!test? ( test )"
+# Without static-libs, src_test just won't run any tests and "pass".
REQUIRED_USE="
test? ( static-libs )
"
@@ -32,11 +32,11 @@ multilib_src_configure() {
-DENABLE_LIB_ONLY=ON
-DENABLE_STATIC_LIB=$(usex static-libs)
-DENABLE_EXAMPLES=OFF
+ -DBUILD_TESTING=$(usex test)
)
- use test && mycmakeargs+=( -DBUILD_TESTING=ON )
cmake_src_configure
}
multilib_src_test() {
- multilib_is_native_abi && cmake_build check
+ cmake_build check
}