summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/lftp-4.7.5.ebuild3
-rw-r--r--net-ftp/lftp/lftp-4.8.2.ebuild3
-rw-r--r--net-ftp/lftp/lftp-4.8.3.ebuild3
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild3
4 files changed, 8 insertions, 4 deletions
diff --git a/net-ftp/lftp/lftp-4.7.5.ebuild b/net-ftp/lftp/lftp-4.7.5.ebuild
index 087b60b4d88a..138bce2efdea 100644
--- a/net-ftp/lftp/lftp-4.7.5.ebuild
+++ b/net-ftp/lftp/lftp-4.7.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils libtool
+inherit autotools eutils libtool multilib
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -76,6 +76,7 @@ src_configure() {
$(usex ssl "$(use_with !gnutls openssl ${EPREFIX}/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
--enable-packager-mode \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \
--with-readline="${EPREFIX}"/usr \
diff --git a/net-ftp/lftp/lftp-4.8.2.ebuild b/net-ftp/lftp/lftp-4.8.2.ebuild
index ca93056b2641..a6577ffe126d 100644
--- a/net-ftp/lftp/lftp-4.8.2.ebuild
+++ b/net-ftp/lftp/lftp-4.8.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils libtool
+inherit autotools eutils libtool multilib
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -79,6 +79,7 @@ src_configure() {
$(usex ssl "$(use_with !gnutls openssl ${EPREFIX}/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
--enable-packager-mode \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \
--with-readline="${EPREFIX}"/usr \
diff --git a/net-ftp/lftp/lftp-4.8.3.ebuild b/net-ftp/lftp/lftp-4.8.3.ebuild
index ca93056b2641..a6577ffe126d 100644
--- a/net-ftp/lftp/lftp-4.8.3.ebuild
+++ b/net-ftp/lftp/lftp-4.8.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils libtool
+inherit autotools eutils libtool multilib
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -79,6 +79,7 @@ src_configure() {
$(usex ssl "$(use_with !gnutls openssl ${EPREFIX}/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
--enable-packager-mode \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \
--with-readline="${EPREFIX}"/usr \
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index c6930de30ea4..75206b992406 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils git-r3 libtool
+inherit autotools eutils git-r3 libtool multilib
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -74,6 +74,7 @@ src_configure() {
$(usex ssl "$(use_with !gnutls openssl ${EPREFIX}/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
--enable-packager-mode \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \
--with-readline="${EPREFIX}"/usr \