summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/Manifest1
-rw-r--r--media-sound/ecasound/ecasound-2.9.3.ebuild97
-rw-r--r--media-sound/ecasound/files/ecasound-2.9.3-ldflags.patch61
3 files changed, 159 insertions, 0 deletions
diff --git a/media-sound/ecasound/Manifest b/media-sound/ecasound/Manifest
index b3b2a85d8143..8945b895acfc 100644
--- a/media-sound/ecasound/Manifest
+++ b/media-sound/ecasound/Manifest
@@ -1,2 +1,3 @@
DIST ecasound-2.6.0.tar.gz 966629 BLAKE2B 35539d80ea306f2ba38980838895c66a2f5db918854f0bd0d0cd1513d0cdaa00a9359337b469a41b8fa42cd88e7642e8393d91fdb1add277edfe77bde633e1cc SHA512 48b3c65e301a775499765c55b09bddacfde24bfd7a5be6c03389c7bda882abe98b061aaa39ec12a797e3a5a2808f446751155b36c263f0f12da2db1495515c5e
DIST ecasound-2.9.1.tar.gz 1057333 BLAKE2B 37e337d379ef649877278a4a3736ef98cde57aeee5a547d3a8e3b9d81785a8a33c964680a6b6871a26d097520f7eab20b186291698869014ec9a12c2ced49b28 SHA512 b91fd68cb4809fdf62b25323fbf52c9bb7de6663287d5aa2576cc4fb28e322850b7020df2718ed6087f5d9f5f96692a476287378ea65853d01834523e8eb7033
+DIST ecasound-2.9.3.tar.gz 1101628 BLAKE2B 52aaa96abee9a911c613ac772fd3df3ff7bb4a8309283089d19e2f7265be26eb6e77304896cda2ed1c71742f36dfe1e38209afd42b921d56f12d43f08b4fe2d2 SHA512 4f70e6f54cd05194a4ffe80905e7488d16d32d684c87736dfdac7b3aebf3d20cbf417964d75e00e781f6f0614b8b699061c69fcbf7e1761d66ce1abfcd5f1140
diff --git a/media-sound/ecasound/ecasound-2.9.3.ebuild b/media-sound/ecasound/ecasound-2.9.3.ebuild
new file mode 100644
index 000000000000..1187b27286c8
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.9.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="a package for multitrack audio processing"
+HOMEPAGE="https://ecasound.seul.org/ecasound/"
+SRC_URI="https://ecasound.seul.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="alsa audiofile debug doc jack libsamplerate lv2 mikmod ncurses oil osc oss
+python ruby sndfile static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lv2 )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="sys-libs/readline:0=
+ alsa? ( media-libs/alsa-lib:= )
+ audiofile? ( media-libs/audiofile:= )
+ jack? ( virtual/jack:= )
+ libsamplerate? ( media-libs/libsamplerate:= )
+ lv2? ( >=media-libs/lilv-0.5.0:= )
+ media-libs/ladspa-sdk
+ mikmod? ( media-libs/libmikmod:0= )
+ ncurses? ( sys-libs/ncurses:0= )
+ oil? ( dev-libs/liboil:= )
+ osc? ( media-libs/liblo:= )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+ sndfile? ( media-libs/libsndfile:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${PN}-2.9.1-tinfo.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+# if use python ; then
+# sed -i -e "s:\$(ecasoundc_libs):\0 $(python_get_library -l):" \
+# pyecasound/Makefile.am || die "sed failed"
+# fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local pyconf=()
+
+ if use python ; then
+ pyconf=( "--with-python-modules=${EPREFIX}/usr/$(get_libdir)/${EPYTHON}" )
+ fi
+
+ econf \
+ --disable-arts \
+ --enable-shared \
+ --enable-sys-readline \
+ --with-largefile \
+ $(use_enable alsa) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable lv2 liblilv) \
+ $(use_enable ncurses) \
+ $(use_enable oil liboil) \
+ $(use_enable osc liblo) \
+ $(use_enable oss) \
+ $(use_enable python pyecasound) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ $(use_enable static-libs static) \
+ "${pyconf[@]}"
+}
+
+src_install() {
+ default
+ use python && python_optimize
+
+ if use doc ; then
+ dodoc Documentation/*.html
+ dodoc Documentation/programmers_guide/ecasound_programmers_guide.txt
+ fi
+
+ find "${ED}" -name "*.la" -delete
+}
diff --git a/media-sound/ecasound/files/ecasound-2.9.3-ldflags.patch b/media-sound/ecasound/files/ecasound-2.9.3-ldflags.patch
new file mode 100644
index 000000000000..86011507fd7b
--- /dev/null
+++ b/media-sound/ecasound/files/ecasound-2.9.3-ldflags.patch
@@ -0,0 +1,61 @@
+diff --git a/kvutils/Makefile.am b/kvutils/Makefile.am
+index ed2bc03..f12a01a 100644
+--- a/kvutils/Makefile.am
++++ b/kvutils/Makefile.am
+@@ -56,13 +56,12 @@ kvutil_headers = kvu_dbc.h \
+ kvu_value_queue.h
+
+ libkvutils_la_SOURCES = $(kvutil_sources) $(kvutil_headers)
+-libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@ -static
++libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@
+
+ libkvutils_debug_la_SOURCES = $(libkvutils_la_SOURCES)
+ libkvutils_debug_la_LDFLAGS = $(libkvutils_la_LDFLAGS)
+
+ libkvutils_tester_SOURCES = libkvutils_tester.cpp
+-libkvutils_tester_LDFLAGS = -static
+ libkvutils_tester_LDADD = $(lib_LTLIBRARIES)
+
+ noinst_HEADERS = $(kvutil_headers)
+diff --git a/libecasound/Makefile.am b/libecasound/Makefile.am
+index 87203cf..dca62bc 100644
+--- a/libecasound/Makefile.am
++++ b/libecasound/Makefile.am
+@@ -368,7 +368,7 @@ libecasound_tester_src = \
+
+ libecasound_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
+ libecasound_debug_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
+-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
++libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags)
+ libecasound_la_LIBADD = $(eca_libadd)
+ libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
+ libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)
+diff --git a/libecasound/plugins/Makefile.am b/libecasound/plugins/Makefile.am
+index 4ea5a92..80a3093 100644
+--- a/libecasound/plugins/Makefile.am
++++ b/libecasound/plugins/Makefile.am
+@@ -105,7 +105,7 @@ plugin_all_sources = $(all_af_src) \
+ libecasound_plugins_la_SOURCES = audioio_dummy.cpp $(plugin_cond_sources)
+ EXTRA_libecasound_plugins_la_SOURCES = $(plugin_all_sources)
+ libecasound_plugins_la_LIBADD = $(ECA_S_EXTRA_LIBS)
+-libecasound_plugins_la_LDFLAGS = -static
++libecasound_plugins_la_LDFLAGS =
+
+ libecasound_plugins_debug_la_SOURCES = $(libecasound_plugins_la_SOURCES)
+ EXTRA_libecasound_plugins_debug_la_SOURCES = $(EXTRA_libecasound_plugins_la_SOURCES)
+diff --git a/libecasoundc/Makefile.am b/libecasoundc/Makefile.am
+index 74ba20c..0f4527e 100644
+--- a/libecasoundc/Makefile.am
++++ b/libecasoundc/Makefile.am
+@@ -14,9 +14,9 @@ AUTOMAKE_OPTIONS = foreign
+ # !!!
+ # remember to update eca-version.cpp
+ if ECA_AM_DEBUG_MODE
+-eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
++eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@
+ else
+-eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
++eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@
+ endif
+
+ AM_CPPFLAGS = -I$(srcdir)