summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-mplayer/files')
-rw-r--r--media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff33
-rw-r--r--media-plugins/vdr-mplayer/files/confd-0.9.15.sh11
-rw-r--r--media-plugins/vdr-mplayer/files/mplayersources.conf3
-rw-r--r--media-plugins/vdr-mplayer/files/rc-addon-0.9.15.sh23
-rw-r--r--media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.1-glibc-2.10.patch12
5 files changed, 82 insertions, 0 deletions
diff --git a/media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff b/media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff
new file mode 100644
index 000000000000..6eb95c7239ca
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff
@@ -0,0 +1,33 @@
+diff -Naur mp3-0.10.1.orig/Makefile mp3-0.10.1/Makefile
+--- mp3-0.10.1.orig/Makefile 2008-03-02 16:58:40.988974674 +0100
++++ mp3-0.10.1/Makefile 2008-03-02 16:59:36.879557750 +0100
+@@ -24,14 +24,14 @@
+ # in the VDR directory an set them there.
+
+ ### uncomment one of these lines, if you don't want one of the plugins
+-#WITHOUT_MP3=1
++WITHOUT_MP3=1
+ #WITHOUT_MPLAYER=1
+
+ ### uncomment the following line, if you don't have libsndfile installed
+-#WITHOUT_LIBSNDFILE=1
++WITHOUT_LIBSNDFILE=1
+
+ ### uncomment the following line, if you don't have libvorbisfile installed
+-#WITHOUT_LIBVORBISFILE=1
++WITHOUT_LIBVORBISFILE=1
+
+ ### uncomment the following line, if you want OSS sound output
+ #WITH_OSS_OUTPUT=1
+diff -Naur mp3-0.10.1.orig/mplayer.c mp3-0.10.1/mplayer.c
+--- mp3-0.10.1.orig/mplayer.c 2008-03-02 16:58:41.068960305 +0100
++++ mp3-0.10.1/mplayer.c 2008-03-02 17:00:53.845333952 +0100
+@@ -832,7 +832,7 @@
+ #else
+ i18n_name="vdr-mplayer";
+ #endif
+- MPlaySources.Load(AddDirectory(ConfigDirectory(sourcesSub),"mplayersources.conf"));
++ MPlaySources.Load(AddDirectory(ConfigDirectory(sourcesSub),"mplayer/mplayersources.conf"));
+ if(MPlaySources.Count()<1) {
+ esyslog("ERROR: you must have defined at least one source in mplayersources.conf");
+ fprintf(stderr,"No source(s) defined in mplayersources.conf\n");
diff --git a/media-plugins/vdr-mplayer/files/confd-0.9.15.sh b/media-plugins/vdr-mplayer/files/confd-0.9.15.sh
new file mode 100644
index 000000000000..b336c5b9e5a1
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/confd-0.9.15.sh
@@ -0,0 +1,11 @@
+# Global config file for vdr mplayer plugin
+#
+# Restart of VDR is needed after changes
+
+
+# Selected the script to call mplayer
+#
+# allowed value: mplay.sh mplayer.sh
+# default value: prefer the first installed from the listed possibilities
+#
+#MPLAYER_PLUGIN_CALL="mplay.sh"
diff --git a/media-plugins/vdr-mplayer/files/mplayersources.conf b/media-plugins/vdr-mplayer/files/mplayersources.conf
new file mode 100644
index 000000000000..96858a41f028
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/mplayersources.conf
@@ -0,0 +1,3 @@
+/var/vdr/video;Video-Verzeichnis;0
+/mnt/cdrom;CDRom;1
+
diff --git a/media-plugins/vdr-mplayer/files/rc-addon-0.9.15.sh b/media-plugins/vdr-mplayer/files/rc-addon-0.9.15.sh
new file mode 100644
index 000000000000..c2de41b208f0
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/rc-addon-0.9.15.sh
@@ -0,0 +1,23 @@
+# $Id$
+#
+# rc-addon plugin-startup-skript for vdr-mplayer
+#
+
+: ${MPLAYER_PLUGIN_CALL:=mplay.sh}
+: ${MPLAYER_PLUGIN_MOUNT:=mount-mplayer.sh}
+
+plugin_pre_vdr_start() {
+ local P=/usr/share/vdr/mplayer/bin
+ local CALL=""
+ if [ -f $P/${MPLAYER_PLUGIN_CALL} ]; then
+ CALL=${MPLAYER_PLUGIN_CALL}
+ elif [ -f $P/mplay.sh ]; then
+ CALL=mplay.sh
+ elif [ -f $P/mplayer.sh ]; then
+ CALL=mplayer.sh
+ else
+ eerror "vdr-mplayer: No mplayer-script found"
+ fi
+ add_plugin_param "-m ${P}/${MPLAYER_PLUGIN_MOUNT}"
+ add_plugin_param "-M ${P}/${CALL}"
+}
diff --git a/media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.1-glibc-2.10.patch b/media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.1-glibc-2.10.patch
new file mode 100644
index 000000000000..a70d214b4e0b
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.1-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur mp3-0.10.1.orig/data.c mp3-0.10.1/data.c
+--- mp3-0.10.1.orig/data.c 2006-05-16 20:31:09.000000000 +0300
++++ mp3-0.10.1/data.c 2009-08-11 12:22:35.000000000 +0300
+@@ -420,7 +420,7 @@
+ description=strdup(Description);
+ if(Include) {
+ do {
+- char *s=index(Include,'/');
++ char *s=const_cast<char*> (index(Include,'/'));
+ int l=s ? s-Include : strlen(Include);
+ if(l) {
+ char **s=(char **)realloc(include,(incCount+2)*sizeof(char *));