summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/frei0r-plugins/files/frei0r-plugins-1.1.22-no-automagic-deps.patch')
-rw-r--r--media-plugins/frei0r-plugins/files/frei0r-plugins-1.1.22-no-automagic-deps.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-plugins/frei0r-plugins/files/frei0r-plugins-1.1.22-no-automagic-deps.patch b/media-plugins/frei0r-plugins/files/frei0r-plugins-1.1.22-no-automagic-deps.patch
new file mode 100644
index 000000000000..142a9a8c24f9
--- /dev/null
+++ b/media-plugins/frei0r-plugins/files/frei0r-plugins-1.1.22-no-automagic-deps.patch
@@ -0,0 +1,47 @@
+--- orig/configure.ac 2008-10-28 11:57:18.000000000 +0100
++++ patched/configure.ac 2009-07-05 15:19:37.000000000 +0200
+@@ -11,12 +11,18 @@
+ AC_PROG_CC
+ AC_PROG_LIBTOOL
+
++
++AC_ARG_ENABLE([facedetect], [ --enable-facedetect enable facedetect plugin (needs opencv)],
++ [facedetect=${enableval}], [facedetect=no])
++
+ HAVE_OPENCV=false
+-PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
+-if test x$HAVE_OPENCV = xfalse; then
+- AC_MSG_WARN([*** opencv >= 1.0.0 not found - this program enables optional plugin with the Open Source Computer Vision library >= 1.0.0 http://opencvlibrary.sourceforge.net/ ***])
+-else
+- OPENCV_CFLAGS="$OPENCV_CFLAGS -DOPENCV_PREFIX=`pkg-config opencv --variable=prefix`"
++if test "x${facedetect}" = xyes; then
++ PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
++ if test x$HAVE_OPENCV = xfalse; then
++ AC_MSG_WARN([*** opencv >= 1.0.0 not found - this program enables optional plugin with the Open Source Computer Vision library >= 1.0.0 http://opencvlibrary.sourceforge.net/ ***])
++ else
++ OPENCV_CFLAGS="$OPENCV_CFLAGS -DOPENCV_PREFIX=`pkg-config opencv --variable=prefix`"
++ fi
+ fi
+ AM_CONDITIONAL([HAVE_OPENCV], [test x$HAVE_OPENCV = xtrue])
+
+@@ -35,11 +41,16 @@
+ AC_FUNC_MALLOC
+ AC_CHECK_FUNCS([floor memset pow sqrt])
+
++
++AC_ARG_ENABLE([scale0tilt], [ --enable-scale0tilt enable scale0tilt plugin (needs gavl)],
++ [scale0tilt=${enableval}], [scale0tilt=no])
++
+ HAVE_GAVL=false
+-PKG_CHECK_MODULES(GAVL, gavl >= 0.2.3, [HAVE_GAVL=true], [true])
+-if test x$HAVE_GAVL = xfalse; then
+- AC_MSG_WARN([*** gavl >= 0.2.3 not found - this program enables optional plugin with the gmerlin audio
+- video library >= 0.2.3 http://gmerlin.sourceforge.net/ ***])
++if test "x${scale0tilt}" = xyes; then
++ PKG_CHECK_MODULES(GAVL, gavl >= 0.2.3, [HAVE_GAVL=true], [true])
++ if test x$HAVE_GAVL = xfalse; then
++ AC_MSG_WARN([*** gavl >= 0.2.3 not found - this program enables optional plugin with the gmerlin audio video library >= 0.2.3 http://gmerlin.sourceforge.net/ ***])
++ fi
+ fi
+ AM_CONDITIONAL([HAVE_GAVL], [test x$HAVE_GAVL = xtrue])
+