summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/osl/osl-1.12.14.0-r1.ebuild')
-rw-r--r--media-libs/osl/osl-1.12.14.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/osl/osl-1.12.14.0-r1.ebuild b/media-libs/osl/osl-1.12.14.0-r1.ebuild
index 628b4123b45d..e450385f5016 100644
--- a/media-libs/osl/osl-1.12.14.0-r1.ebuild
+++ b/media-libs/osl/osl-1.12.14.0-r1.ebuild
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="doc gui libcxx nofma partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma partio qt6 test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -177,11 +177,16 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DUSE_OPTIX="no"
- -DVEC_REPORT="yes"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT="yes" )
if ! use qt6; then