summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/cura/cura-0.15.04.5_rc5.ebuild')
-rw-r--r--media-gfx/cura/cura-0.15.04.5_rc5.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/media-gfx/cura/cura-0.15.04.5_rc5.ebuild b/media-gfx/cura/cura-0.15.04.5_rc5.ebuild
index ac952093c028..c35602d8d18b 100644
--- a/media-gfx/cura/cura-0.15.04.5_rc5.ebuild
+++ b/media-gfx/cura/cura-0.15.04.5_rc5.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils fdo-mime gnome2-utils python-single-r1
+
+inherit desktop gnome2-utils python-single-r1 xdg-utils
MY_PV=${PV#0.}
MY_PV=${MY_PV/_rc/-RC}
@@ -30,9 +31,12 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}
>=dev-python/setuptools-0.6.34[${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/${PN}-0.15.04.4-nopower.patch" )
S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15.04.4-nopower.patch"
+)
+
src_prepare() {
cat > "${T}"/cura <<- CURAEOF || die
#!/bin/sh
@@ -62,13 +66,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}