summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.30.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 4cc7d912277b..d29b14017c12 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST syntax-highlighting-5.29.0.tar.xz 883920 SHA256 cbcca052a1ad79b4d1ed1209d6f8e9ba0c3812dc158b26c4a8232a8d879c7839 SHA512 c01e1d53a37410e72342a545ecc30606a6dac98f991786f49bd8600ba4bc92a23c13b69088b30ad015e16380ae1c699467bacb21f86b75b7201f39895f2d4a5c WHIRLPOOL 8b37878b357bdbd9a999c6c0d5641697523666e350867e7d79b2313dafe233bd883fb3d439e3379874edd9d1ca36c42e11958fd20484405b56c234bf63960a99
+DIST syntax-highlighting-5.30.0.tar.xz 974816 SHA256 a3d4d68c45f95133b4f242be24ecf88620478bbcd84ced1f1bea080667783746 SHA512 5e494bced095dce9cd10cfc55a628b7afc81279393f1b907e0a9d302aed87d5e659d231293d14b75c4564ec9dddada7824bd4e795405bf2f5642aa345b524480 WHIRLPOOL f2d1df0d09b2d96ac5dec4817b3a8f637879047afa1a598a60b2b94b457f39df72c20cea2ef42132b3d8e454a5ae8801829b091abc538b13c3e0fc4e48943235
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.30.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.30.0.ebuild
new file mode 100644
index 000000000000..cc84fb092d9b
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.30.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxmlpatterns)
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ test? ( $(add_qt_dep qtwidgets) )
+"
+
+src_install() {
+ kde5_src_install
+ dobin "${BUILD_DIR}"/src/indexer/katehighlightingindexer
+}