summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/ski')
-rw-r--r--games-sports/ski/Manifest2
-rw-r--r--games-sports/ski/metadata.xml5
-rw-r--r--games-sports/ski/ski-6.8.ebuild34
-rw-r--r--games-sports/ski/ski-6.9.ebuild34
4 files changed, 75 insertions, 0 deletions
diff --git a/games-sports/ski/Manifest b/games-sports/ski/Manifest
new file mode 100644
index 000000000000..45cd3d4f1ef6
--- /dev/null
+++ b/games-sports/ski/Manifest
@@ -0,0 +1,2 @@
+DIST ski-6.8.tar.gz 17119 SHA256 776849dc61ffe834def7d22b9027a64491559a1700351d817313f187cee36c4d SHA512 0e63b6d34e809d74ddaea3749e6d1df44907ebe26bc19185b6c9cc6998f538747cb32a747fd0b4307bf05beec65564f1174e982a851270e344117d943f4ecca9 WHIRLPOOL ff730a786e7961170545c5dbe9f26c0030e78a9cf422e60791e90cb02098b7c0352489b08af16838a1b4f48dca3bb8b9e386d665dd537094482de937dfccc08d
+DIST ski-6.9.tar.gz 17543 SHA256 d0f2fd7770a63319340fab8ee275c6221dff0e0e7fe488f2298f567583902d37 SHA512 bdcd9a267153b23bc1e4b99f0073d9d26ff8a8d670d70ec06cc27b91cd4a3bdaf821507671d73a359b3447261d52e596c61cbf9596eead7191102d1a089178b6 WHIRLPOOL ee31f8ddcfb28111e353be6162fc6e49ce2f8aa45d3f57e34e7343a4e4244a4be59ae026cbd27a08b0c4f4f7660d8558a945cd1bcfd8778d23f2c337c8296b5c
diff --git a/games-sports/ski/metadata.xml b/games-sports/ski/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-sports/ski/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-sports/ski/ski-6.8.ebuild b/games-sports/ski/ski-6.8.ebuild
new file mode 100644
index 000000000000..010180304d7a
--- /dev/null
+++ b/games-sports/ski/ski-6.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 games
+
+DESCRIPTION="A simple text-mode skiing game"
+HOMEPAGE="http://www.catb.org/~esr/ski/"
+SRC_URI="http://www.catb.org/~esr/ski/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ games_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dogamesbin ski
+ dodoc NEWS README
+ doman ski.6
+ domenu ski.desktop
+ doicon ski.png
+ prepgamesdirs
+ python_fix_shebang "${ED}${GAMES_BINDIR}"
+}
diff --git a/games-sports/ski/ski-6.9.ebuild b/games-sports/ski/ski-6.9.ebuild
new file mode 100644
index 000000000000..dd760911b186
--- /dev/null
+++ b/games-sports/ski/ski-6.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 games
+
+DESCRIPTION="A simple text-mode skiing game"
+HOMEPAGE="http://www.catb.org/~esr/ski/"
+SRC_URI="http://www.catb.org/~esr/ski/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ games_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dogamesbin ski
+ dodoc NEWS README
+ doman ski.6
+ domenu ski.desktop
+ doicon ski.png
+ prepgamesdirs
+ python_fix_shebang "${ED}${GAMES_BINDIR}"
+}