summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/moon-buggy/moon-buggy-1.0.51.ebuild')
-rw-r--r--games-action/moon-buggy/moon-buggy-1.0.51.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-action/moon-buggy/moon-buggy-1.0.51.ebuild b/games-action/moon-buggy/moon-buggy-1.0.51.ebuild
new file mode 100644
index 000000000000..4a9cfc0d57f8
--- /dev/null
+++ b/games-action/moon-buggy/moon-buggy-1.0.51.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
+HOMEPAGE="http://www.seehuhn.de/comp/moon-buggy.html"
+SRC_URI="http://www.seehuhn.de/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e '/$(DESTDIR)$(bindir)\/moon-buggy -c/d' \
+ Makefile.am || die
+ rm -f missing
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --sharedstatedir="${GAMES_STATEDIR}" \
+ --with-curses-libs="$(pkg-config ncurses --libs)"
+}
+
+src_install() {
+ default
+ touch "${D}${GAMES_STATEDIR}"/${PN}/mbscore
+ fperms 664 "${GAMES_STATEDIR}"/${PN}/mbscore
+ prepgamesdirs
+}