summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scanmem/files/scanmem-0.13-configure.patch')
-rw-r--r--dev-util/scanmem/files/scanmem-0.13-configure.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/scanmem/files/scanmem-0.13-configure.patch b/dev-util/scanmem/files/scanmem-0.13-configure.patch
new file mode 100644
index 000000000000..cedc96a07098
--- /dev/null
+++ b/dev-util/scanmem/files/scanmem-0.13-configure.patch
@@ -0,0 +1,31 @@
+--- scanmem-0.13/configure.ac
++++ scanmem-0.13/configure.ac
+@@ -108,16 +108,17 @@
+ test/Makefile
+ ])
+
+-AC_ARG_ENABLE(gui, [AS_HELP_STRING([--enable-gui],
+- [enable gameconqueror, the gui front-end of scanmem])],
+- [enable_gui=true
+- AC_CONFIG_FILES([
+- gui/Makefile
+- gui/consts.py
+- gui/gameconqueror
+- ])],
+- [enable_gui=false]
+- )
++AC_ARG_ENABLE([gui],
++ AS_HELP_STRING([--enable-gui],
++ [enable gameconqueror, the gui front-end of scanmem]))
+
+-AM_CONDITIONAL([ENABLE_GUI], [test x$enable_gui = xtrue])
++AS_IF([test "x$enable_gui" = "xyes"], [
++ AC_CONFIG_FILES([
++ gui/Makefile
++ gui/consts.py
++ gui/gameconqueror
++ ])
++])
++
++AM_CONDITIONAL([ENABLE_GUI], [test "x$enable_gui" = "xyes"])
+ AC_OUTPUT