summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 7e1fffdd38ab..6a4fce0ea524 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi
DESCRIPTION="pkgcore-based QA utility"
@@ -20,11 +20,16 @@ HOMEPAGE="https://github.com/pkgcore/pkgcheck"
LICENSE="|| ( BSD GPL-2 )"
SLOT="0"
-RDEPEND="
- =sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
- =dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="
+ =dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ =sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND="
+ >=dev-python/snakeoil-0.7.2[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.9.5[${PYTHON_USEDEP}]"
+fi
+RDEPEND+=" dev-python/lxml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"