summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest3
-rw-r--r--dev-ruby/mixlib-shellout/metadata.xml8
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild27
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.0.1.ebuild27
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.1.0.ebuild27
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
new file mode 100644
index 000000000000..587ca9db44fd
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -0,0 +1,3 @@
+DIST mixlib-shellout-1.6.1.tar.gz 30601 SHA256 98949512840f800283b2b065b1b2c605e4b899e0b950624b8f84ab17b0d07dc8 SHA512 1a95e4b5520695808e03d45b8b3889b3a343d3d76561572ca99f705998fb68a0f7bbb0b6ca5655cc454d71f4cba24ff07cde7f0301bfcca803e66104cf885f15 WHIRLPOOL 7c2e4a2df53fa820f61ff231a66ea97590e0198e8c4b5d5ba92d3d1ba0714184c681bc66060e1fb54dfedd61dbc96938ee19cf2618c1345767605520d43d93d7
+DIST mixlib-shellout-2.0.1.tar.gz 31038 SHA256 f1a64b5882b125acf87fc9699a2c461a5e7dff443d9bc76fa8f3f25798a60044 SHA512 224952f0114dd39d31d0401bbccbf76d60b9461559b742223c0e8b95600bb3d9938957c03a4cdefc06898c5cb4035539a10298698052ebf42ed41dd9a3384cc1 WHIRLPOOL c86738088ed920c695b4b07900ca801de7ae4fb5856c736cbeaa211fca362ee4a658c64487d4933ed0a822f8a44167ccd3fbda64c8d97981e9bd8f840c837a54
+DIST mixlib-shellout-2.1.0.tar.gz 32800 SHA256 8dcc6ae1be5dc3055808b3d40a9155520e6188f1772f6f5e4ecf037ab7a5283d SHA512 15fef2f9b661ac02edecfd4c48b00866e34bc361f2070da4382991e0455ab15650327209cbcae153fcface727c47efc75d7f9dac2a92867fd148941942f117d8 WHIRLPOOL 7e039b721d73d2b4531a3d69224358c67e2afb3d051cd1cf21380a1c47b23523c2e1115184542999fee4f63f9bdafd64e4d67d3133d269043f2828449d374e02
diff --git a/dev-ruby/mixlib-shellout/metadata.xml b/dev-ruby/mixlib-shellout/metadata.xml
new file mode 100644
index 000000000000..7d58544aed1e
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">opscode/mixlib-shellout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild
new file mode 100644
index 000000000000..998eaf9c6550
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="http://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.0.1.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.0.1.ebuild
new file mode 100644
index 000000000000..998eaf9c6550
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="http://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.1.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.1.0.ebuild
new file mode 100644
index 000000000000..6d1fc6f7db65
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}