summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/readme/readme-0.5.1.ebuild')
-rw-r--r--dev-python/readme/readme-0.5.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/readme/readme-0.5.1.ebuild b/dev-python/readme/readme-0.5.1.ebuild
deleted file mode 100644
index 5d0a865a6f54..000000000000
--- a/dev-python/readme/readme-0.5.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="a library for rendering \"readme\" descriptions for Warehouse"
-HOMEPAGE="https://github.com/pypa/readme https://pypi.python.org/pypi/readme"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-DOCS=( README.rst )
-
-python_prepare_all() {
- # remove failing test for now
- rm tests/fixtures/test_rst_008* || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}