summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/polib')
-rw-r--r--dev-python/polib/files/polib-1.0.7-BE-test.patch11
-rw-r--r--dev-python/polib/polib-1.0.7.ebuild4
-rw-r--r--dev-python/polib/polib-1.1.0.ebuild4
3 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/polib/files/polib-1.0.7-BE-test.patch b/dev-python/polib/files/polib-1.0.7-BE-test.patch
new file mode 100644
index 000000000000..e2192bb7091b
--- /dev/null
+++ b/dev-python/polib/files/polib-1.0.7-BE-test.patch
@@ -0,0 +1,11 @@
+https://bitbucket.org/izi/polib/pull-requests/24/tests-force-msgfmt-into-machines-byte/diff
+https://bugs.gentoo.org/641464
+diff --git a/tests/tests.py b/tests/tests.py
+index 50ad0c6..239ce88 100644
+--- a/tests/tests.py
++++ b/tests/tests.py
+@@ -551,3 +551,3 @@ class TestPoFile(unittest.TestCase):
+ po.save_as_mofile(tmpfile1)
+- subprocess.call([msgfmt, '--no-hash', '-o', tmpfile2, reffile])
++ subprocess.call([msgfmt, '--no-hash', '--endianness=%s' % sys.byteorder, '-o', tmpfile2, reffile])
+ try:
diff --git a/dev-python/polib/polib-1.0.7.ebuild b/dev-python/polib/polib-1.0.7.ebuild
index 73369498a496..c890aa984407 100644
--- a/dev-python/polib/polib-1.0.7.ebuild
+++ b/dev-python/polib/polib-1.0.7.ebuild
@@ -17,6 +17,10 @@ IUSE="doc"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
python_compile_all() {
use doc && emake -C docs html
}
diff --git a/dev-python/polib/polib-1.1.0.ebuild b/dev-python/polib/polib-1.1.0.ebuild
index ea885b2aaf88..81c5318f275d 100644
--- a/dev-python/polib/polib-1.1.0.ebuild
+++ b/dev-python/polib/polib-1.1.0.ebuild
@@ -17,6 +17,10 @@ IUSE="doc"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
python_compile_all() {
use doc && emake -C docs html
}