summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/automat/automat-20.2.0-r1.ebuild')
-rw-r--r--dev-python/automat/automat-20.2.0-r1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/automat/automat-20.2.0-r1.ebuild b/dev-python/automat/automat-20.2.0-r1.ebuild
deleted file mode 100644
index ef3ee70bfe81..000000000000
--- a/dev-python/automat/automat-20.2.0-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=${P^}
-DESCRIPTION="Self-service finite-state machines for the programmer on the go"
-HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
-SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/test_visualize-twisted-import-errors.patch"
- "${FILESDIR}/${P}-py311.patch"
- "${FILESDIR}/${PN}-20.2.0-ignore-m2r.patch"
-)
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- benchmark
-)
-
-src_prepare() {
- # strip m2r dep
- sed -i -e "/'m2r'/d" setup.py || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc docs/examples/*.py
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo "For additional visualization functionality install both these optional dependencies"
- einfo " >=dev-python/twisted-16.1.1"
- einfo " media-gfx/graphviz[python]"
-}