summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlpdf/camlpdf-2.1.1.ebuild')
-rw-r--r--dev-ml/camlpdf/camlpdf-2.1.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
index 83226661473c..8ba49799866b 100644
--- a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
+++ b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit findlib
+inherit findlib eutils
DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
@@ -19,6 +19,10 @@ IUSE="doc examples"
RDEPEND="dev-lang/ocaml:="
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/ocaml43.patch"
+}
+
src_compile() {
# parallel make bugs
emake -j1